Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-10-2008, 07:57 PM   #1
Baseband Member
 
Join Date: May 2006
Posts: 43
Default In need of some help

Ok I built me a pc. its all together but when I try to turn it on. I have nothing. its dead. I don't know what is going on with it the motherboard I am using is a K8T800-A7A By Biostar. If anyone has any help that would be great. Thank you
__________________

Ty_Lawrence is offline   Reply With Quote
Old 02-10-2008, 08:05 PM   #2
Fully Optimized
 
A True Folder's Avatar
 
Join Date: Jan 2007
Posts: 2,789
Default Re: In need of some help

give us a description of all the components please mate.

1/. It's plugged into a wall socket yes?
2/. the little switch on the psu is turned on yes?
3/. Does the LED on the m/board light up?
__________________

__________________
E8600@ 4.25GHz, 1.325V | Thermalright Ultra 120 eXtreme + Scythe Slipstream 120 | Asus Rampage Extreme| 4GB Corsair 2000MHz 8-8-8-24 @ 1600 6-7-6-24| ASUS 9800GTX| Pioneer 18X SATA DVD-RW | 320GB + 500GB WD SATAII | Antec True Power Trio 650W | Thermaltake Sonata | Vista Ultimate x64 SP2/Win7 Ultimate
A True Folder is offline   Reply With Quote
Old 02-10-2008, 08:15 PM   #3
Golden Master
 
borat_sagdiyev's Avatar
 
Join Date: Feb 2006
Posts: 8,986
Send a message via AIM to borat_sagdiyev Send a message via MSN to borat_sagdiyev
Default Re: In need of some help

are the front panel buttons hooked up to the right pins on the motherboard?
__________________
Core 2 Duo e4500 2.2ghz @ 2.8ghz
evga 650i ultra
2gb 400mhz ram OC'ed to 450
evga geforce 7600GT overclocked
borat_sagdiyev is offline   Reply With Quote
Old 02-10-2008, 10:37 PM   #4
Baseband Member
 
Join Date: May 2006
Posts: 43
Default Re: In need of some help

yes everything is hooked up. NO there is no led light on the motherboard.
Ty_Lawrence is offline   Reply With Quote
Old 02-10-2008, 10:45 PM   #5
Fully Optimized
 
A True Folder's Avatar
 
Join Date: Jan 2007
Posts: 2,789
Default Re: In need of some help

If the LED on the m/board isn't lit up then there are two options

1/. dead psu
2/. dead m/board

You can check the psu by grounding the green wire, if it is good it will fire up and if it does then the m/board is the culprit

Obviously if it doesn't then the psu is faulty.
__________________
E8600@ 4.25GHz, 1.325V | Thermalright Ultra 120 eXtreme + Scythe Slipstream 120 | Asus Rampage Extreme| 4GB Corsair 2000MHz 8-8-8-24 @ 1600 6-7-6-24| ASUS 9800GTX| Pioneer 18X SATA DVD-RW | 320GB + 500GB WD SATAII | Antec True Power Trio 650W | Thermaltake Sonata | Vista Ultimate x64 SP2/Win7 Ultimate
A True Folder is offline   Reply With Quote
Old 02-10-2008, 10:49 PM   #6
Baseband Member
 
Join Date: May 2006
Posts: 43
Default Re: In need of some help

How would you ground the green wire??
Ty_Lawrence is offline   Reply With Quote
Old 02-10-2008, 11:00 PM   #7
Fully Optimized
 
A True Folder's Avatar
 
Join Date: Jan 2007
Posts: 2,789
Default Re: In need of some help

Read this LINK

If you're still unsure I would suggest seeking help from a pc/electronics repair store.
__________________
E8600@ 4.25GHz, 1.325V | Thermalright Ultra 120 eXtreme + Scythe Slipstream 120 | Asus Rampage Extreme| 4GB Corsair 2000MHz 8-8-8-24 @ 1600 6-7-6-24| ASUS 9800GTX| Pioneer 18X SATA DVD-RW | 320GB + 500GB WD SATAII | Antec True Power Trio 650W | Thermaltake Sonata | Vista Ultimate x64 SP2/Win7 Ultimate
A True Folder is offline   Reply With Quote
Old 02-11-2008, 05:20 AM   #8
BSOD
 
internetprob's Avatar
 
Join Date: Feb 2008
Posts: 84
Default Re: In need of some help

Yes also test motherboard in another computer.
__________________

internetprob is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0