Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-10-2005, 10:49 PM   #1
aCb
In Runtime
 
aCb's Avatar
 
Join Date: Dec 2004
Posts: 319
Default Need help with new case.

Ok so I got the Scoprio 868 on newegg and put all my parts in correctly (100% sure of this) and nothing happened when I turned it on. I then used a meter to test the switches and they worked fine. I read the reviews on newegg and a few people said their cases came with dead PSU so newegg sent me a new case and I have everything in the case now and having the same problem. So I thought my motherboard wasnt working but when I put everything else in the other computer case I had it worked fine.

I just emailed raidmax and hopefully they will respond soon does anyone know what my problem is. There is 1 connector on the PSU that I wasnt sure what it was for and the other case didnt have im thinking this is the problem. I know everything is connected correctly and the computer works fine.
__________________

__________________
INTEL CORE 2 DUO E6420
ASUS P5N-E SLI nVIDIA nFORCE 650 SLI
CRUCIAL BALLISTIX 2GB 667MHZ 3-3-3-12
RADEON X1950 PRO
aCb is offline   Reply With Quote
Old 02-10-2005, 10:56 PM   #2
BSOD
 
DarkBlade's Avatar
 
Join Date: Dec 2004
Posts: 3,355
Send a message via MSN to DarkBlade
Default Re: Need help with new case.

Hmm, odd... Maybe two dead PSUs? That would be strange though. If there is a 4 pin 12v rail, plug it into your mobo as well if you can.
__________________

DarkBlade is offline   Reply With Quote
Old 02-10-2005, 11:03 PM   #3
aCb
In Runtime
 
aCb's Avatar
 
Join Date: Dec 2004
Posts: 319
Default

thats already in and i doubt the first one even had a dead PSU I just have no idea why its not working. On the raidmax site theres also a guide for my case to hook it up and everything and nothing is wrong its just not turning on.
__________________
INTEL CORE 2 DUO E6420
ASUS P5N-E SLI nVIDIA nFORCE 650 SLI
CRUCIAL BALLISTIX 2GB 667MHZ 3-3-3-12
RADEON X1950 PRO
aCb is offline   Reply With Quote
Old 02-10-2005, 11:04 PM   #4
BSOD
 
DarkBlade's Avatar
 
Join Date: Dec 2004
Posts: 3,355
Send a message via MSN to DarkBlade
Default Re: Need help with new case.

Oddness... I don't know on this problems, never used RaidMax and don't plan on it.
DarkBlade is offline   Reply With Quote
Old 02-11-2005, 07:56 PM   #5
aCb
In Runtime
 
aCb's Avatar
 
Join Date: Dec 2004
Posts: 319
Default

ok figured the problem out... another dead PSU.
__________________
INTEL CORE 2 DUO E6420
ASUS P5N-E SLI nVIDIA nFORCE 650 SLI
CRUCIAL BALLISTIX 2GB 667MHZ 3-3-3-12
RADEON X1950 PRO
aCb is offline   Reply With Quote
Old 02-11-2005, 08:35 PM   #6
Daemon Poster
 
TibsBeatAll's Avatar
 
Join Date: Jun 2004
Posts: 790
Default Re: Need help with new case.

one unlucky fellow you are.

Thats why i only trust brands like antec or thermaltake when i buy cases.
__________________
Athlon 64 3800+ @ 2.8 ghz.
Leadtek 6800 350/700 PCI express, different from before.
80 gig Samsung HD SATA x 2
1024 Kingston Hyperx Ram
TibsBeatAll is offline   Reply With Quote
Old 02-11-2005, 10:01 PM   #7
aCb
In Runtime
 
aCb's Avatar
 
Join Date: Dec 2004
Posts: 319
Default

well last time newegg would either give me 25$ credit for a new PSU or get a new case and I got the new case. I hope they do the same deal again and I will just get the 25$ credit and purchase a decent PSU (if anyone can give me some good onoes for around 35$ max please do) I saw the thermaltake 420 for 38$ might get that. But if newegg doesnt give me 25$ credit again Raidmax will send me a new PSU but I have to pay for shipping to send the old one back to them.
__________________
INTEL CORE 2 DUO E6420
ASUS P5N-E SLI nVIDIA nFORCE 650 SLI
CRUCIAL BALLISTIX 2GB 667MHZ 3-3-3-12
RADEON X1950 PRO
aCb is offline   Reply With Quote
Old 02-11-2005, 10:15 PM   #8
Daemon Poster
 
TibsBeatAll's Avatar
 
Join Date: Jun 2004
Posts: 790
Default Re: Need help with new case.

The thermaltake is good. Lots of wires and is very rock solid.

I have one in my second rig. It's very, very stable.

There is a downside however, it isn't as silent as it claims. By no means is it a vacuum, but it still isn't silent. I
__________________

__________________
Athlon 64 3800+ @ 2.8 ghz.
Leadtek 6800 350/700 PCI express, different from before.
80 gig Samsung HD SATA x 2
1024 Kingston Hyperx Ram
TibsBeatAll is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0