Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 09-01-2011, 04:39 PM   #1
In Runtime
220racer's Avatar
Join Date: Aug 2011
Posts: 130
Default Need Help With New Build

I ordered some new parts for a computer build, They have recently arrived, and I assembled the computer. There was nothing wrong with what I did (For what I know) And whenever i try to power it up, only the motherboard lights up, please help?
ENERMAX LuxuRay ATX Mid Tower Computer Case
AMD Phenom II X4 955 Black Edition 3.6 GHz
XFX Radeon 6870 256-bit 2GB
ASUS M5A97 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD Motherboard
Seagate Barracuda 500GB 7200 RPM SATA 6.0Gb/s 3.5" Internal Hard Drive
Kingston HyperX 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600
RAIDMAX HYBRID 2 RX-730SS 730W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular
Sony Optiarc CD/DVD Burner Black SATA Model AD-7260S-0B - OEM
Microsoft Windows 7 Home Premium
220racer is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 11:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0