Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 03-19-2007, 09:44 PM   #1
Beta Member
Join Date: Mar 2007
Posts: 1
Question Need help!!!

Hi I'm new to this board and I was just wondering if anybody could help me out. I just bought a motherboard (ecs pt890t-a) and realised that it doesn't have any onboard video outputs. So I installed my video card that I already had but it still doesn't do anything. The screen just stay black. I am using the ATI Radeon 9200. I have not installed anything onto my hd (no os, or anything) cause I can't see anything. This is a custom built cpu, and everything went well up until this point. Any help would be greatly appreciated. Thanks in advance.


mojo21 is offline   Reply With Quote
Old 03-20-2007, 02:38 PM   #2
Golden Master
Tommy Boy's Avatar
Join Date: Jul 2004
Location: USA
Posts: 8,463
Send a message via Yahoo to Tommy Boy
Default Re: Need help!!!

Well, the first thing you need to do is double check everything, like is the video card in the right spot and firmly seated? Check your cables to the monitor and make sure the monitor is plugged in and the cables are tight. If you have another monitor you might want to try that to make sure that the monitor isn't bad. Try another video card if you have one to make sure the video card isn't bad.

I would say either your video card is dead or for whatever reason the AGP slot on your motherboard isn't working and you should probably return your motherboard and get a new (better) one. ECS isn't known for making good motherboards.

When all else fails...Ham Radio!

I still have the same old HP DV9700T laptop I've had for years...still kickin'
Tommy Boy is offline   Reply With Quote
Old 03-20-2007, 05:15 PM   #3
Join Date: Apr 2005
Posts: 6,556
Send a message via MSN to Rudster816
Default Re: Need help!!!

if every thing is secure and connected does your BIOS give off any beep codes? if not then you probaly got a DOA mobo or CPU. if you can try installing widows with another computer at your side to use as a screen to guide you. if you do make sure to wait a little longer when it come up on the 2nd screen otherwise it may still be loading. when doing so turn you speakers way up so if any sound comes out you will hear it.
Rudster816 is offline   Reply With Quote
Old 03-20-2007, 06:31 PM   #4
In Runtime
Join Date: Dec 2006
Posts: 145
Default Re: Need help!!!

Unless i looked at the wrong board and card, your video card is ethier AGP or PCI.
Looks like your MB only does PCI-express.
Just something to check
Ocelot is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 03:47 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0