Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 07-02-2008, 01:23 PM   #1
Baseband Member
Join Date: Oct 2007
Posts: 49
Default my power supply problem

hello. recently my computer's power supply died on me, so i ordered this power supply as a replacement. I got it today and I plugged in my hard drives and dvd drives, then the 20 pin connector, then i tried the 4 pin connector and the pattern on the new one doesn't match the female input on the motherboard. Do I need to get another power supply?

if it helps my computer is a compaq presario with a 2.13 GHz amd processor. 996mb(i believe, should be close to 1 gig) of ram, 1 80 gig hard drive, 1 180gig hard drive. then two dvd burners.

thanks in advance!

nosignal is offline   Reply With Quote
Old 07-02-2008, 02:00 PM   #2
Join Date: Oct 2004
Location: England
Posts: 6,224
Default Re: my power supply problem

no you just need a pin connecter converter thing for your motherbored, cost you about 3pound,

IAntDemo is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 09:57 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0