Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-17-2008, 09:04 PM   #1
Baseband Member
 
Join Date: Sep 2008
Posts: 53
Default My New PSU Works

I got my new PSU, and it worked.

Graphics look phenominal now, atleast when compared to how they looked before.

Though, I think there may be some bottlenecking going on. It first began running WoW on 90 FPS, and after about an hour it went down to 50 FPS average. There is also the occassional skip. I'm thinking of upgrading to 4GB of RAM (even though I've XP and probably don't need that much).

Still, it's wonderful.
__________________

AmagicalFishy is offline   Reply With Quote
Old 11-17-2008, 09:04 PM   #2
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: My New PSU Works

Excellent news!
__________________

Atomic Rooster is offline   Reply With Quote
Old 11-17-2008, 09:12 PM   #3
Fully Optimized
 
LukaszR's Avatar
 
Join Date: May 2008
Posts: 2,833
Send a message via MSN to LukaszR
Default Re: My New PSU Works

Quote:
Originally Posted by Atomic Rooster View Post
Excellent news!
Indeed!
__________________
Desktop - DualBoot: Fedora 15/Windows 7 64bit
Netbook - Windows 7 Professional

www.Cyber-Talk.ca League of Legends and Gaming Community
LukaszR is offline   Reply With Quote
Old 11-17-2008, 09:19 PM   #4
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: My New PSU Works

Don't you mean GPU?
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 11-17-2008, 09:29 PM   #5
Baseband Member
 
Join Date: Sep 2008
Posts: 53
Default Re: My New PSU Works

Nein. PSU (Power Supply)
AmagicalFishy is offline   Reply With Quote
Old 11-17-2008, 09:35 PM   #6
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: My New PSU Works

Quote:
Originally Posted by Kage View Post
Don't you mean GPU?
Nope: http://www.computerforums.org/showthread.php?t=78628
Atomic Rooster is offline   Reply With Quote
Old 11-17-2008, 09:48 PM   #7
Golden Master
 
Cabbs's Avatar
 
Join Date: Jan 2006
Posts: 7,912
Send a message via AIM to Cabbs
Default Re: My New PSU Works

Glad that it works
__________________
=Like anime? Come to AnimeAppeal.com!=
||DFI UT P35||Q9550@3400 Mhz||Geil 4GB RAM||Radeon 5770||
Cabbs is offline   Reply With Quote
Old 11-17-2008, 10:02 PM   #8
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: My New PSU Works

Ah, glad it works now then
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 11-18-2008, 07:45 AM   #9
Daemon Poster
 
Join Date: Dec 2007
Posts: 694
Default Re: My New PSU Works

sweet
rifle is offline   Reply With Quote
Old 11-20-2008, 11:25 AM   #10
Solid State Member
 
Join Date: Nov 2008
Posts: 7
Default Re: My New PSU Works

i didn't know that could affect performence? unless your overclocking?
__________________

wackacon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0