Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-15-2010, 04:38 AM   #1
Beta Member
 
Join Date: Feb 2010
Posts: 3
Default My new laptop, why doesn't it run simple games?

I have just bought a new laptop

HP Envy 15 with 1.6Ghz Core i7, 4GB RAM and a ati 4830 mob radeon with 1GB dedicated.

I installed Company of Heroes last night and it runs really stuttery even when i turn the graphics and model detail right down, and also turn the performance settings win win7 to high performance.

I would of thought these specs would be easily high enough for this? Even the diagnostics at the start of the game said my computer exceeds recommended.

I have already updated my GPU drivers (ATI Catalyst).

Does anyone know what could be the problem??

Thanks
__________________

Davidcowling is offline   Reply With Quote
Old 02-15-2010, 04:43 AM   #2
In Runtime
 
Join Date: Jan 2010
Posts: 320
Default Re: My new laptop, why doesn't it run simple games?

Is that the first thing you have installed on the laptop?

Try looking on the task manager, and seeing the CPU % used before the game, just normal processes, and then in game, and a few other times

Does anything else run poorly?
__________________

Luke_Uk_Baggy is offline   Reply With Quote
Old 02-15-2010, 05:57 AM   #3
Beta Member
 
Join Date: Feb 2010
Posts: 3
Default Re: My new laptop, why doesn't it run simple games?

I will have a look when i get home (at work atm).

Do you think this is a CPU problem? i have limited tech knowledge, but i would of assumed the GPU would be at fault.

how do i check CPU % whilst in game?

i checked it on system properties before starting and it was 0% occasionally jump to 1%

when i run the game, and open the system properties then the game just stops until i click back on the window, therefore making the CPU freq go right down.

Running trackmania nations forever with no real problems.

any help is appreciated!
Davidcowling is offline   Reply With Quote
Old 02-17-2010, 08:11 PM   #4
Solid State Member
 
Kapoody's Avatar
 
Join Date: Feb 2010
Posts: 16
Send a message via MSN to Kapoody
Default Re: My new laptop, why doesn't it run simple games?

Dont run the game in full screen(if its an option) and maybe you have the screen resolution to high for your screen
Kapoody is offline   Reply With Quote
Old 02-17-2010, 09:54 PM   #5
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: My new laptop, why doesn't it run simple games?

That's very odd, those specs should be plenty... maybe check in the bios to see if everything is at the proper speeds?
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 02-17-2010, 10:06 PM   #6
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: My new laptop, why doesn't it run simple games?

What are in-game temps?
__________________

foothead is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0