Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 11-19-2010, 11:31 PM   #11
Daemon Poster
GibsonSGKing's Avatar
Join Date: Jan 2009
Posts: 1,384
Default Re: My computer EXPLODED... or so it seemed...

Originally Posted by mikee286 View Post
I heard that switching to the UK 230 setting while in the US just doesn't allow the computer to boot but if you are in the UK and switch it to US setting will fry components since the psu will be set to receive 110v and receive 230v and break the psu
Pretty much. You can obviously see that more voltage (More than double in this case) is certainly a much bigger problem that less voltage. Electricity is not something you want to mess with, especially not in Europe. It kills, plain and simple.

C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 01:02 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0