Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 06-20-2008, 01:24 PM   #1
Beta Member
Join Date: May 2008
Posts: 4
Exclamation Jittery photo editing

I have a p4, 1.5G ram and a ATI Diamond X1050 video card.
The problem that I'm having is that when I'm doing photo or movie editing. While editing with Photoshop Elements, when program opens, the screen jitters a little and then after editing 8 or 9 pictures, it goes to the gray box that states that Windows explorer is shutting down the program and do I want to report it. If I do any editing rapidly such as quickly brushing in a large area, it will do the same thing...SHUT DOWN". The video card is brand new, 1Gig of the RAM is new and the other 512mb is older.

This problem only occurs on photo or movie editing programs.
1 Photoshop Elements
2. Microsoft Digital Image Pro
3. Paint Pro
4. Roxio Video

The video program freezes pretty quickly so I have to work on a few..then save...work on a few...then save...so on so on.

Any one of you wonderfully talented, technologically advanced minds out there wanna give me an answer to this problem that I have encountered?? I'm confused..as usual..and need HELP! Thanks in advance!

By the way...this shutdown ONLY happens on media editing programs. The Roxio Media Creator suite works fine and so does everything else...just media editing.

chrt396 is offline   Reply With Quote
Old 06-20-2008, 04:14 PM   #2
Golden Master
Kage's Avatar
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: Jittery photo editing


This is in the wrong place, so I'll move it to the Computer section.

What specs have you got? This will help us decide what is the cause.

Could be the RAM, as intensive programs like that will use a lot more memory than casual programs will.

Hope we can help

Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 06-22-2008, 12:34 AM   #3
Beta Member
Join Date: May 2008
Posts: 4
Default Re: Jittery photo editing

What kind of specs are we speaking of? The X1050 has 256Mb...and I just upgraded to another Radeon HD 2600 Pro video card today w/ 512Mb. I upgraded power supply to 550w and RAM up to 2Gb. The program still jitters a bit nut I have not tried to load a bunch of edited photos as of yet. I'll keep ya posted.
chrt396 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 02:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0