Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-22-2009, 01:56 PM   #1
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default I got a 4870 and wasn't expecting much of an increase in performance...

but none...? wow, that amazed me...no, actually disappointed me, I started up S.T.A.L.K.E.R. Shadow of Chernobyl and didn't really notice much of a difference, I was thinking of playing Crysis through again (last time was on my 4850) so I ran 3DMark06 and got the exact same results with the 4870 as I did with the 4850, actually the 4870 score was 1 pt less, the cpu score was lower but I figured the 4870 would make up for the lower overclock on my Q6600 compared to the higher overclock I ran it with on my E6600 (3.00GHz quad vs 3.2GHz duo)...

WTF...?
__________________

__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 08-22-2009, 02:08 PM   #2
j03
~~~~~~~~
 
Join Date: Jan 2005
Location: Wales
Posts: 5,556
Send a message via MSN to j03
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

You sure you put the right card in...? :P

That sucks. Is everything as it should be in GPU-Z?
__________________

j03 is offline   Reply With Quote
Old 08-22-2009, 02:14 PM   #3
Fully Optimized
 
rohan23's Avatar
 
Join Date: Sep 2008
Posts: 4,087
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

You're running at 1680x1050 aren't you? That's why. Try running Crysis where you will definitely see a difference, or try running 3DMark Vantage.
__________________
Macook 13.3

2.13Ghz Intel Core 2 Duo-2GB DDR2 800 Mhz-500GB Western Digital Caviar Blue- Nvidia 9400M
rohan23 is offline   Reply With Quote
Old 08-22-2009, 02:19 PM   #4
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

Quote:
Originally Posted by j03 View Post
You sure you put the right card in...? :P

That sucks. Is everything as it should be in GPU-Z?
yeah, I've even already flashed the bios twice after editing it in RBE, after the first flash the fan was acting funky, cycling between 0% and 81% back and forth because I think I set the Tslope too steep, I evened it out a bit for the second flash and it's working better now, I'm thinking about putting the ASUS TOP 4870 bios on it, that's the popular one IIRC...

Quote:
Originally Posted by rohan23 View Post
You're running at 1680x1050 aren't you? That's why. Try running Crysis where you will definitely see a difference, or try running 3DMark Vantage.
damn, lol, forgot all about resolution, thanks Rohan...

I think I'll try Vantage...
__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 08-22-2009, 02:54 PM   #5
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

You "upgraded" from a 4850 to a 4870? I hope you didn't spend much for the card.
Atomic Rooster is offline   Reply With Quote
Old 08-22-2009, 03:02 PM   #6
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

Quote:
Originally Posted by Atomic Rooster View Post
You "upgraded" from a 4850 to a 4870? I hope you didn't spend much for the card.
$85 USD, I've got a few friends who I can sell my 4850 to (or just keep it as a back up), either way, the price was minimal...
__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 08-22-2009, 03:18 PM   #7
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

You're doing it wrong.

Of course there is a difference between the 4850 and the 4870.
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 08-22-2009, 03:18 PM   #8
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

That's $85 too much for the minimal performance increase, if any.
Atomic Rooster is offline   Reply With Quote
Old 08-22-2009, 06:02 PM   #9
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

He spent $85 on the card I think.
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 08-22-2009, 06:02 PM   #10
Baseband Member
 
alienJJ's Avatar
 
Join Date: Aug 2009
Posts: 27
Default Re: I got a 4870 and wasn't expecting much of an increase in performance...

you should wait longer for a better upgrade or shouldve spent a lil more for something like a 4870x2 or 4890 at least
__________________

__________________
Custom Computers: http://www.seongs.com
alienJJ is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0