Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-11-2010, 10:00 PM   #1
In Runtime
 
Join Date: Nov 2005
Posts: 321
Default HTPC is killing my power cords!

Hey guys,
My HTPC runs fairly well, and recently I gave it a new Thermaltake PSU.
But, for the second time, it has stopped turning on (or in fact receiving power at all - the ethernet port usually lights up when it has power). And, for the second time, it's been a case of swapping the AC power cord!

I've never had AC power cords die before, so is it just a coincidence that it has happened twice on the same computer? I doubt it. Could it be the power board ?

-Rhys
__________________

RhysAndrews is offline   Reply With Quote
Old 05-11-2010, 10:28 PM   #2
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: HTPC is killing my power cords!

Quote:
Originally Posted by RhysAndrews View Post
Hey guys,
My HTPC runs fairly well, and recently I gave it a new Thermaltake PSU.
But, for the second time, it has stopped turning on (or in fact receiving power at all - the ethernet port usually lights up when it has power). And, for the second time, it's been a case of swapping the AC power cord!

I've never had AC power cords die before, so is it just a coincidence that it has happened twice on the same computer? I doubt it. Could it be the power board ?

-Rhys
There's no way the computer fried the power cord. The most possible explanation I can think of is that the connector on the PSU is bending the connections in the cord?
__________________

__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-11-2010, 10:29 PM   #3
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: HTPC is killing my power cords!

My brother used to have a Tt PSU, and the plug on the back was oddly loose. The cord would slowly slip farther back until it made no connection. Any chance this is the case?

If not, then it is something I have never heard of. The only way the power cord would fry from the psu is if it draws way more current than the cord is rated for. Standard PC power cords can carry 15 amps iirc, so this is not the case.

Are there any sharp bends in it?
foothead is offline   Reply With Quote
Old 05-11-2010, 10:43 PM   #4
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: HTPC is killing my power cords!

Quote:
Originally Posted by foothead View Post
My brother used to have a Tt PSU, and the plug on the back was oddly loose. The cord would slowly slip farther back until it made no connection. Any chance this is the case?

If not, then it is something I have never heard of. The only way the power cord would fry from the psu is if it draws way more current than the cord is rated for. Standard PC power cords can carry 15 amps iirc, so this is not the case.

Are there any sharp bends in it?
Yeah, it would have to pull an insane amount of amperage to fry the cord.


And maybe it's the outlet killing it?
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-12-2010, 10:32 PM   #5
In Runtime
 
Join Date: Nov 2005
Posts: 321
Default Re: HTPC is killing my power cords!

My mistake. This time, it wasn't the power cord.
It was the first time though, which is very strange.

I suspect the motherboard has died, this time. The PSU is only a few months old and it's a good quality PSU. The motherboard has been problematic for a while, though.

Thanks for your help,
-Rhys
RhysAndrews is offline   Reply With Quote
Old 05-12-2010, 10:35 PM   #6
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: HTPC is killing my power cords!

Quote:
Originally Posted by RhysAndrews View Post
My mistake. This time, it wasn't the power cord.
It was the first time though, which is very strange.

I suspect the motherboard has died, this time. The PSU is only a few months old and it's a good quality PSU. The motherboard has been problematic for a while, though.

Thanks for your help,
-Rhys
Thermaltake PSUs are usually terrible quality. Have you actually tested the PSU?
__________________

foothead is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0