Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-04-2010, 09:57 AM   #1
Daemon Poster
 
madanchi's Avatar
 
Join Date: Oct 2008
Posts: 529
Default hmm aoe3 and odd lag?

so strange thing is, aoe3 lags when in huge battles with particles effects everywere. So, I heard that as aoe3 is an old game, it was made for dual core and not quad. So im thinking thats the reason why as its not made for quad. is there any way to only use 2 cores instead of 4? I couldnt find it in ATI CCC

also it slighlty jolt lags when scrolling into a new parts of the map which it hasnt been on screen for that game, after its its been on screen it runs smooth

thanks in advance
__________________

__________________
6950 flashed to 6970 Oc:880cpu 1300memory,2x2gb ddr3 1066,phenomII x4 955 3.2ghz,Tuniq hsf,750w psu,1tb f2 32mb 7200rpm,2tb f4 64mb 7200rpm,cyborg V7, cyborg V3, X-fi creative sounfblaster, Audiophile M-audio,Xclio-windtunnel,Tb7300 graphics tablet
madanchi is offline   Reply With Quote
Old 04-04-2010, 06:06 PM   #2
Daemon Poster
 
Join Date: Sep 2009
Posts: 732
Default Re: hmm aoe3 and odd lag?

you shouldnt have a problem with a dual core vs a quad core, AoE3 just wont use the extra cores. i have this problem too on my desktop but my friend doesnt on his. Im thinking that it could be that AoE3 just doesnt like widescreen monitors(most 23" monitors are widescreen), my friend has a 22" which not widescreen.

and btw this happens to me with any strategy games even newer ones like R.U.S.E so im pretty sure that its your monitor.
__________________

__________________
My Desktop: Intel Core i7-970@4.5GHz 1.39V Stable--ASUS P6X58D-E--6GB Supertalent Chrome (Elpida Hyper) 1800MHz 6-6-6-24--eVGA GTX 580--Intel 510 120GB--WD 2TB Caviar Black--Silverstone RV03-EK Supreme HF w/ Black Ice GTX 480--Koolance VID-NX580

My Laptop: Intel Core 2 Duo @ 2.4GHz--4GB DDR2 800MHz RAM--NVIDIA GeForce 8600M GT-320GB hard drive
shozzking is offline   Reply With Quote
Old 04-04-2010, 06:10 PM   #3
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: hmm aoe3 and odd lag?

That is very odd, but I have heard that the extra threads can cause some issues in games, if they decide to scale, and share when the game doesn't support threading.

Try opening up the Windows Task Manager while the game is running and going to Processes. Track the game down, and right click, and go to Affinity.

De-select two cores, or even three and Apply it, and carry on running the game.

Does the problem go away?
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 04-04-2010, 08:21 PM   #4
Baseband Member
 
quadmasterevan's Avatar
 
Join Date: Apr 2010
Posts: 76
Send a message via AIM to quadmasterevan
Default Re: hmm aoe3 and odd lag?

question does this happen when you play over the lan or against the computer, ive had issues where it will lag over the lan but as apposed to regualar game play it worked fine. this is a great annoyance tho when the game lags
quadmasterevan is offline   Reply With Quote
Old 04-05-2010, 12:19 AM   #5
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: hmm aoe3 and odd lag?

Disabling two cores won't make it run faster, people say it's better on dual cores because dual cores are clocked faster. So if the game is only threaded for 2 cores, it will run faster with the processor that has the faster clock speed (assuming they have the same architecture)
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 04-05-2010, 07:22 AM   #6
Daemon Poster
 
madanchi's Avatar
 
Join Date: Oct 2008
Posts: 529
Default Re: hmm aoe3 and odd lag?

right, I think it might be the widescreen monitor like shozzking said, I disbaled cores - didnt work, even when only running it with one. and I havnt tried lan, only have ever tried on computer players

either aoe3 doesnt like amd/ ati or its just being a pain

thanks for the help anyway
__________________
6950 flashed to 6970 Oc:880cpu 1300memory,2x2gb ddr3 1066,phenomII x4 955 3.2ghz,Tuniq hsf,750w psu,1tb f2 32mb 7200rpm,2tb f4 64mb 7200rpm,cyborg V7, cyborg V3, X-fi creative sounfblaster, Audiophile M-audio,Xclio-windtunnel,Tb7300 graphics tablet
madanchi is offline   Reply With Quote
Old 04-05-2010, 07:30 AM   #7
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: hmm aoe3 and odd lag?

Try running at a none wide screen resolution in a window. If that works, it can't really be the monitor.

Also:

http://www.agecommunity.com/gameUpdates.aspx
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 04-05-2010, 12:16 PM   #8
Daemon Poster
 
disturbed13's Avatar
 
Join Date: Jul 2007
Posts: 1,154
Send a message via Yahoo to disturbed13
Default Re: hmm aoe3 and odd lag?

we are talking age of empires 3 right?
cuz i have a quad and................ well maybe not
when i play, all of my cores are used. i wonder if iTunes sucks so much that it takes 2 cores to run
__________________

__________________
If you think you can, you CAN! If you think you cant, your right.
<iframe src="http://www.worldcommunitygrid.org/getDynamicImage.do?memberName=disturbed13&mnOn=tru e&stat=1&imageNum=4&rankOn=false&projectsOn=false& special=false" frameborder="0" name="di" scrolling="no" width="125px" height="176px"></iframe>
disturbed13 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0