Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-15-2017, 02:11 PM   #1
In Runtime
 
Join Date: Jun 2015
Location: England
Posts: 211
Default Help! No sign of life

I have just gone to restart new build comouter been running perfect for days upon restart once the power went off it never came back on

There are no lights on the motherboard and no fans spinning no response from pressing power buttons

My PSU came with a tester I used it before I installed it the other day all was fine

I have just tried the tester again and no response from the PSU

What's wrong ? If the PSU has failed it see so to me what are the chances it has took the rest of the components with it
__________________

Sharpy is offline   Reply With Quote
Old 10-15-2017, 03:28 PM   #2
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,767
Default Re: Help! No sign of life

You have power from the wall?
__________________

__________________
I yam what I yam
Celery is offline   Reply With Quote
Old 10-15-2017, 03:35 PM   #3
In Runtime
 
Join Date: Jun 2015
Location: England
Posts: 211
Default Re: Help! No sign of life

Hi celery Yh there is power coming from the wall lights and everything else in house are working but the Psu is not responding to nothing as far as u can tell


I'm pretty upset about it worried more than anything as you no first build but all was good

I'm not used to how returns on Amazon work if the PSU has took out other components would I be able to return them too?
Sharpy is offline   Reply With Quote
Old 10-15-2017, 03:59 PM   #4
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,767
Default Re: Help! No sign of life

I don't know about the return policy but let's make sure it's the PSU. The switch is on right?

Let's start with the power button (no pun intended). Unplug the power button and touch the power button pins on the board with a coin or a screwdriver and see if that works.

I have a feeling you have a poorly made case.
__________________
I yam what I yam
Celery is offline   Reply With Quote
Old 10-15-2017, 04:00 PM   #5
Daemon Poster
 
AMD_man's Avatar
 
Join Date: Dec 2016
Location: Argentina
Posts: 729
Default Re: Help! No sign of life

Well that sucks. Could you describe what happened? Did the power go out and then came back and fried it? Did anything else in the house get fried?

If the problem was a power surge then I don't think EVGA will give you your money back, since it's not their fault. If you can't test yourself you should take it to a shop, they'll have spare parts to test. Once you know what the problem is you can start making calls.

Do you have another PSU to try the other components?
__________________
"You fool. Don't you understand? No one wishes to go onů"
AMD_man is offline   Reply With Quote
Old 10-15-2017, 04:05 PM   #6
In Runtime
 
Join Date: Jun 2015
Location: England
Posts: 211
Default Re: Help! No sign of life

You can test the PSU with nothing attached the fan started too spin

Now nothing happens.

I aren't sure what happened there was no sign of failure it just didn't come back on think the shutdown was successful and it happened when power Maby returned nothing else in the house was effected it was contained too the computer as far as I can tell no lights or devices in the house went off and I do have other computers running

No spare parts no real computer shops around here

I wish I has a spare PSU I'm very worried about the other parts
Sharpy is offline   Reply With Quote
Old 10-15-2017, 04:07 PM   #7
Daemon Poster
 
AMD_man's Avatar
 
Join Date: Dec 2016
Location: Argentina
Posts: 729
Default Re: Help! No sign of life

So what's exactly happening now? What happens when everything is correctly plugged in? Did you make any changes before trying to turn it on?
__________________
"You fool. Don't you understand? No one wishes to go onů"
AMD_man is offline   Reply With Quote
Old 10-15-2017, 04:07 PM   #8
In Runtime
 
Join Date: Nov 2014
Location: UK
Posts: 452
Default Re: Help! No sign of life

If you say you have tested it with a tester and it has given no response then it's a pretty sure bet that it is the power supply. The first thing you have to do is get that PSU replaced. Then you have to make sure that all the standoffs for the mother board are in the right place and none of them are shorting the board. Unfortunately the only way you can test it is by substitution and if something on the board has blown the power supply it will blow it again. Bottom line as far as I am concerned is that providing that you haven't caused this failure then everything should be sent back to the supplier for testing and they should replace whatever is faulty. The biggest problem with online suppliers that I have found is that you cannot go and bang on tables when they get shirty. Having said that 99% of suppliers do take my word for it. You just have to make sure that isn't something you have done that has caused the problem.
pete.i is offline   Reply With Quote
Old 10-15-2017, 04:09 PM   #9
In Runtime
 
Join Date: Jun 2015
Location: England
Posts: 211
Default Re: Help! No sign of life

It's dead nothing is happening now no lights on the mb no fans spinning

I removed a USB stick just before restart (I don't believe that caused it)

The tester came with the PSU it's essentially the paperclip method it just makes the PSU start spinning its fan

My supplier was Amazon

I don't want refunds just replacements to whats needed

Do they often fail like that it was very unexpected with everything working fine for days
Sharpy is offline   Reply With Quote
Old 10-15-2017, 05:21 PM   #10
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,767
Default Re: Help! No sign of life

Do you have an extra PSU to test with?
__________________

__________________
I yam what I yam
Celery is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0