Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 07-01-2012, 07:35 PM   #1
Beta Member
Join Date: Jul 2012
Location: USA
Posts: 1
Unhappy help me i have a strange problem with my PC

2 days ago i have done installing my new pc
my computer specs is

motherboard gigabyte P61A-D3
Core i5 2500 2.80ghz
kingstone 4gb ram
HD 7850 GDRR5 (2GB)
Samsung cd dvd drive
WD 500 HDD
600 watt PSU coolmax

i have installed everything the correct way and everything seems to work. the cpu fan is running and the graphics card fan is running too everything seems to work well but there is no display i don't have a monitor that supports DVI i'm use an 20 inch HDTV i have used it with 3 high end graphics cards and it works well using hdmi but right now my new pc doesn't display anything on the screen i have tried both hdmi and dvi to vga converter becasue my hdtv supports vga i've tried them both but i still get nothing on the screen it makes me sad it's been 2 days i can't get to the bios and install my copy of windows

if you are an expert please tell me what's wrong with my build

apollox is offline   Reply With Quote
Old 07-01-2012, 08:48 PM   #2
Site Team
celegorm's Avatar
Join Date: Sep 2006
Posts: 10,674
Send a message via AIM to celegorm
Default Re: help me i have a strange problem with my PC

Try re-seating the RAM, video card(s) and all the power connections. If that doesn't work try using known good RAM and a known good power supply to isolate those parts as a problem. Also try unplugging all devices like hard drives so only the Video card, RAM, and CPU are plugged in to eliminate any of the connected devices as a possible cause of you not getting video.

"as a fanboy i refuse to admit it and will pull countless things out of my butt to disprove it"

Team Thelegorm! Total Kills: 21 (i iz in uor profile, editsing your sigz)
celegorm is offline   Reply With Quote
Old 07-02-2012, 04:10 AM   #3
Fully Optimized
Join Date: Apr 2012
Location: England, Birmingham
Posts: 1,561
Default Re: help me i have a strange problem with my PC

May seem a daft comment, but: Make sure the monitor is on

Also, unplug the power from the back of the PC, press the poer button on the front 3-4 times, plug it back in and try switching it on again.
joedaman633 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 06:32 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0