Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2011, 06:01 PM   #1
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Exclamation Harddrive Not Being Detected!!

I just put together my computer with all the parts arrived today. The hard drive, which worked on my previous build, does not show up with booting options or in BIOS. My set up is in my signature. The SATA CD/DVD drive shows up fine in all SATA slots on the mobo. The hard drive shows up in none (haven't tested all but the few I did did not work, including the ones that did work for the CD/DVD drive). I have tried multiple SATA cables and power cables. Nada. I used my external hard drive enclosure and it shows up on my laptop, everything working fine. WTF??
__________________

stuiedaman is offline   Reply With Quote
Old 07-14-2011, 06:07 PM   #2
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Harddrive Not Being Detected!!

Go into BIOS and look at the SATA port settings. The ports are probably enabled since you can see other SATA devices, so try setting the port you have the hard drive connected to for Legacy mode.
__________________

__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 07-14-2011, 06:23 PM   #3
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Harddrive Not Being Detected!!

Quote:
Originally Posted by cboucher View Post
Go into BIOS and look at the SATA port settings. The ports are probably enabled since you can see other SATA devices, so try setting the port you have the hard drive connected to for Legacy mode.
Not seeing how. I go in BIOS (Main > SATA Configuration > SATA Port 4) and it gives me these options: LBA/Large Mode, Block (Multi-Sector Transfer), PIO Mode, DMA Mode, S.M.A.R.T., and 32-bit data transfer. All give me the option of auto or disabled, all of them being selected to auto, with the exception PIO Mode which gives me the options of 0-4 and is set to auto.
stuiedaman is offline   Reply With Quote
Old 07-14-2011, 06:27 PM   #4
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Harddrive Not Being Detected!!

Do you have the manual for the motherboard? If not, I would just disable each option one at a time and see what happens.
__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 07-14-2011, 06:30 PM   #5
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Harddrive Not Being Detected!!

I do have a manual, what should I look for exactly?
stuiedaman is offline   Reply With Quote
Old 07-14-2011, 06:32 PM   #6
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Harddrive Not Being Detected!!

Look up what each of those SATA related setting do. Anything that mentions RAID you probably want to disable.
__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 07-14-2011, 06:39 PM   #7
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Harddrive Not Being Detected!!

not saying anything about those settings. It talks about everything else in BIOS though. LOL. nothing sata related. Google?

EDIT: didn't find anything that would help there.
stuiedaman is offline   Reply With Quote
Old 07-14-2011, 07:02 PM   #8
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Harddrive Not Being Detected!!

try disabling each of those settings one at a time and see what happens...
__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 07-14-2011, 07:21 PM   #9
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Harddrive Not Being Detected!!

Quote:
Originally Posted by cboucher View Post
try disabling each of those settings one at a time and see what happens...
nothing
stuiedaman is offline   Reply With Quote
Old 07-15-2011, 02:53 PM   #10
Fully Optimized
 
Indigo's Avatar
 
Join Date: Jul 2010
Location: USA
Posts: 1,866
Default Re: Harddrive Not Being Detected!!

Does putting that drive BACK onto another computer result in it being detected? It sounds like something on the hard drive is kaput. (ESD victim at the very least, incompatibility at the worst - which CAN happen, though it is rare)
__________________

Indigo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0