Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 09-19-2010, 02:41 AM   #1
In Runtime
Join Date: Apr 2007
Posts: 446
Send a message via MSN to Comp_Pro
Default Harddrive error

One of my harddrives on my desktop has a few problems.

I have 2 harddrives, a 160gb one with windows 7 on it and a 1tb one with data on it.

Now the problem I have with this computer is when I go to access my 1tb harddrive my computer freezez for about 10 seconds then I hear the drive spin up and hear a click then my computer will unfreeze and this really frustrates me and I have a program that records my games and when I start to record my game it will take extra long to start the harddrive which causes my game to crash and my recording to corrupt.

How do I fix this problem? I just want to harddrive to be spinning all the time like my main harddrive so i can read and write on demand and not have to wait and have my computer freeze. Big flaw in the windows 7 OS

Intel i7 4770k 3.50ghz, 32gb Corsair Vengeance RAM (8x4 kit), 2 x 2TB WD Black HHD, nVidia 770GTX 4gb OC, Asus Z87-A Motherboard, running Windows 7 64 bit.
Comp_Pro is offline   Reply With Quote
Old 09-19-2010, 04:04 PM   #2
Fully Optimized
Indigo's Avatar
Join Date: Jul 2010
Location: USA
Posts: 1,866
Default Re: Harddrive error

This isn't some "big flaw" as you mention. This is by design. You just need to change your power settings to not spin hard drives down. I usually prefer to leave mine spinning and absorb the minimal cost of power needed to do that - some argue that the bearings wear out faster, but I haven't had any major issues doing it this way for years.

In Windows 7, just go into your control panel, and I like to set it to show small icons, then locate and click power options, then for the power profile you're currently using (it'll have a dot in it) click "Change Plan Settings." Then click "Change advanced power settings." Click the + next to Hard Disk, then the + next to "Turn off hard disk after" and change the Setting: to 0 and click ok. If you click apply, you'll notice it change the 0 to "never' which is fine. Close out of there and you're all set.

Hard drive lags like this aren't uncommon when the hard drives are spun down and don't always mean that there is a failure in the system. If the behavior continues, then you might want to look into getting another drive just in case.
Indigo is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 04:52 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0