Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-26-2011, 12:38 PM   #1
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Question Hard Drives Not Showing Up on Newly Built PC

So I just built a computer (specs are in my sig) and for some reason my SATA hard drives will not show up in BIOS/boot menu. Both hard drives are good (both work on external enclosure) and all cables and ports work good (all work on my SATA CD/DVD drive). My first hard drive is a Barracuda 7200.11 and you can find some information about this issue here: BIOSTAR :: FAQ. The problem is that the solution involves me using another working hard drive to install the drivers on or an (correct me if I'm wrong, I can't access the page right now) Intel based proccessor. I don't have either. My other hard drive that won't work is a WD. I don't have the specific model as I am at school rght now but I will post that when I get back. Any ideas? Thanks!
__________________

stuiedaman is offline   Reply With Quote
Old 08-26-2011, 09:18 PM   #2
In Runtime
 
HafX's Avatar
 
Join Date: Jun 2011
Posts: 126
Default Re: Hard Drives Not Showing Up on Newly Built PC

Can you verify that both your sata cables as well as your power cables are connected (silly question, but sometimes people forget)

IF your able to boot and get into Windows and you are talking about not being able to see them in your "My Computer" area, then I also have that fix.

Also what else have you tested to assure you that the drives are working?
__________________

__________________
Case: Cooler Master Haf X
CPU: AMD Phenom X4 955 Black Edition Deneb
MOBO: Gigabyte 890FXA-UD7 [4X XFire Support, 6GB Sata Connectors, 16GB RAM Support]
VGA: 2 Sapphire Radeon 5850 Toxic Edition Video Cards Xfire'd
HD: 3TB Western Digital Caviar Black
RAM: 8GB Corsair XMS3 DDR3 Ram
PSU: Corsair 850TX Enthusiast Edition
Drives: 1x Sony Optaric Blu-Ray Drive, 1x Lite-on DVD RW Drive
Cooling: Corsair H-70 Water Cooling
ETC: Razer Mamba Mouse, Logitech Z-5500's, 2x HP 27" 2709m Monitors
HafX is offline   Reply With Quote
Old 08-28-2011, 01:28 AM   #3
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Hard Drives Not Showing Up on Newly Built PC

Quote:
Originally Posted by HafX View Post
Can you verify that both your sata cables as well as your power cables are connected (silly question, but sometimes people forget)

IF your able to boot and get into Windows and you are talking about not being able to see them in your "My Computer" area, then I also have that fix.

Also what else have you tested to assure you that the drives are working?
Yes, all cables are plugged in LOL. To be sure, I boot up, CD/DVD drive appears in boot options with no hard drive shown (but it is connected), I turn off the computer, take the cables plugged into the disk drive and plug it into the hard drive, still doesn't show up. No I am not able to get into windows as I have no drive to install in on. I tested both by using an external enclosure and both show up on the laptop using this and are able to do all necessary tasks.
stuiedaman is offline   Reply With Quote
Old 08-29-2011, 01:29 PM   #4
Fully Optimized
 
Indigo's Avatar
 
Join Date: Jul 2010
Location: USA
Posts: 1,866
Default Re: Hard Drives Not Showing Up on Newly Built PC

Sometimes the board won't show the drive connected until after it detects it a few times. Don't know why some boards are like that, but they are.

Have you tried to install Windows on them and it failed? Or are you just going based off of what the BIOS says?

The CPU won't have anything to do with a hard drive issue in this case.
Indigo is offline   Reply With Quote
Old 08-29-2011, 02:00 PM   #5
In Runtime
 
HafX's Avatar
 
Join Date: Jun 2011
Posts: 126
Default Re: Hard Drives Not Showing Up on Newly Built PC

I agree with the above, I would say attempt to boot from the Windows installation disc, and see if it recognizes the hard drive.
And I will also concur that the CPU will have 0 to do with the hard drive connectivity.
__________________
Case: Cooler Master Haf X
CPU: AMD Phenom X4 955 Black Edition Deneb
MOBO: Gigabyte 890FXA-UD7 [4X XFire Support, 6GB Sata Connectors, 16GB RAM Support]
VGA: 2 Sapphire Radeon 5850 Toxic Edition Video Cards Xfire'd
HD: 3TB Western Digital Caviar Black
RAM: 8GB Corsair XMS3 DDR3 Ram
PSU: Corsair 850TX Enthusiast Edition
Drives: 1x Sony Optaric Blu-Ray Drive, 1x Lite-on DVD RW Drive
Cooling: Corsair H-70 Water Cooling
ETC: Razer Mamba Mouse, Logitech Z-5500's, 2x HP 27" 2709m Monitors
HafX is offline   Reply With Quote
Old 08-29-2011, 08:26 PM   #6
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Hard Drives Not Showing Up on Newly Built PC

I attempted to boot from a Windows disk a while back and it just did the loading windows screen and then a blank screen. I can try it again with the new hard drive. As with the cpu, the website tells of a solution where non-windows based systems can boot from a driver disk if the cpu is Intel compatible
stuiedaman is offline   Reply With Quote
Old 08-30-2011, 01:16 AM   #7
Fully Optimized
 
Indigo's Avatar
 
Join Date: Jul 2010
Location: USA
Posts: 1,866
Default Re: Hard Drives Not Showing Up on Newly Built PC

"Intel compatible" is generic talk for "this may or may not be an issue, but we're posting it anyway to cover our own asses"

I've never run into a case within the past 10 years where having one CPU over another when dealing with Windows was a big deal. Don't read too much into it.
Indigo is offline   Reply With Quote
Old 09-18-2011, 12:11 PM   #8
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Hard Drives Not Showing Up on Newly Built PC

Sooo, what would fix my problem?
stuiedaman is offline   Reply With Quote
Old 09-18-2011, 10:59 PM   #9
Baseband Member
 
Join Date: Jul 2010
Location: United States
Posts: 55
Default Re: Hard Drives Not Showing Up on Newly Built PC

So boot into Windows installation from the disk and when it asks for me to decided on which hard drive to install the windows on, it says there are no hard drives. When i choose install drivers, it brings up my drives (CD/DVD, USB, AND my hard drive). My hard drive is listed as drive X. That's the letter I gave it when I formatted it on my laptop. Why is it showing up under there but not under my drives list?
stuiedaman is offline   Reply With Quote
Old 09-19-2011, 04:25 AM   #10
Fully Optimized
 
cavemangrinder's Avatar
 
Join Date: Oct 2007
Location: USA
Posts: 1,540
Default Re: Hard Drives Not Showing Up on Newly Built PC

Are you trying to install Windows XP? If so, you need to provide the SATA drivers upon installation in order to detect the hard drive. Otherwise, I'd check to make sure all the settings in the BIOS are set correctly, if you've messed with settings already try resetting to Optimized/Fail-Safe settings.
__________________

cavemangrinder is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0