Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-06-2006, 05:43 PM   #1
Daemon Poster
 
Morpheus's Avatar
 
Join Date: Nov 2004
Posts: 1,073
Default Graphics Card Problem

Hi guys I need your help I bought my new graphics card an HIS Excalibur ATi X1650 Pro 512mb http://www.hisdigital.com/html/produ...d=248&view=yes
I installed it and now when ever I try to play a game it will start it and it will flash a black screen two times and it keeps doing it while the game is running I downloaded ATi's latest catalyst drivers 6.9 from ATi's site and when I try to install them it comes up with an error message that the driver can't be found and something about an IVF file. If anyone can help me please let me know otherwise I will have to put my old card back in and that's just wrong.

Thanks
__________________

__________________
Athlon 64 3.500 90nm Winchester Core (overclocked to 3.800)
Asus A8V Rev.2 Deluxe Corsair 2x512MB DDR XMS3200XL Platinum TwinX
HIS ATI Radeon 9800 Pro 128MB DDR IceQ TV-Out/DVI
Sound Blaster Live 2x SATA 200GB WD Hard Drives SX1040BII Black Performance Series II SOHO File Server 430W PSU
Creative Inspire 5.1 P580 Speakers Sharp LL-172G 17" LCD Monitor - Black
Morpheus is offline   Reply With Quote
Old 10-06-2006, 07:46 PM   #2
Daemon Poster
 
PerfectSK's Avatar
 
Join Date: Feb 2006
Posts: 982
Default Re: Graphics Card Problem

Alrite try doing this. Download the 6.5's or 6.3 Catalyst drivers, uninstall the ones you have now, and install the 6.5's or 6.3's. I'm running the 6.3's and its stable.
__________________

__________________
Rig -- Emachines T5026, 3.06ghz P4, 300W Bestec PSU, 160 sata hd, 512mb dual channel 3200 ram @ 3-3-5-8, ATI Radeon 9250 pci, dual layer 16x dvd+/-rw.
PerfectSK is offline   Reply With Quote
Old 10-06-2006, 07:50 PM   #3
Golden Master
 
freestyler105's Avatar
 
Join Date: Sep 2006
Posts: 7,883
Default Re: Graphics Card Problem

^Either that (What perfect said) or reinstall the same drivers. It sounds like there was just something wrong with the drivers.
__________________
C2D E6600 | 4GB DDR2-800 | 9800GTX+ | Asus P5B-E | 150GB Raptor | 320GB 7200.10 | 750W Xigmatek PSU
freestyler105 is offline   Reply With Quote
Old 10-07-2006, 02:40 AM   #4
Daemon Poster
 
Morpheus's Avatar
 
Join Date: Nov 2004
Posts: 1,073
Default Re: Graphics Card Problem

Well I tried reinstalling same problem I will try installing 6.5 thanks guys I knew I could count on you. I'll let you know if it worked.
__________________
Athlon 64 3.500 90nm Winchester Core (overclocked to 3.800)
Asus A8V Rev.2 Deluxe Corsair 2x512MB DDR XMS3200XL Platinum TwinX
HIS ATI Radeon 9800 Pro 128MB DDR IceQ TV-Out/DVI
Sound Blaster Live 2x SATA 200GB WD Hard Drives SX1040BII Black Performance Series II SOHO File Server 430W PSU
Creative Inspire 5.1 P580 Speakers Sharp LL-172G 17" LCD Monitor - Black
Morpheus is offline   Reply With Quote
Old 10-07-2006, 08:42 PM   #5
Daemon Poster
 
Morpheus's Avatar
 
Join Date: Nov 2004
Posts: 1,073
Default Re: Graphics Card Problem

T_T Sad news guys installing 6.5 didn't solve my problem either.
__________________
Athlon 64 3.500 90nm Winchester Core (overclocked to 3.800)
Asus A8V Rev.2 Deluxe Corsair 2x512MB DDR XMS3200XL Platinum TwinX
HIS ATI Radeon 9800 Pro 128MB DDR IceQ TV-Out/DVI
Sound Blaster Live 2x SATA 200GB WD Hard Drives SX1040BII Black Performance Series II SOHO File Server 430W PSU
Creative Inspire 5.1 P580 Speakers Sharp LL-172G 17" LCD Monitor - Black
Morpheus is offline   Reply With Quote
Old 10-23-2006, 12:05 PM   #6
Daemon Poster
 
Morpheus's Avatar
 
Join Date: Nov 2004
Posts: 1,073
Default Re: Graphics Card Problem

Found what the problem was. My PSU wasn't strong enough to handle the new graphics card mine is 400W and they recommend 450W. Once again guys thanks for everything.
__________________

__________________
Athlon 64 3.500 90nm Winchester Core (overclocked to 3.800)
Asus A8V Rev.2 Deluxe Corsair 2x512MB DDR XMS3200XL Platinum TwinX
HIS ATI Radeon 9800 Pro 128MB DDR IceQ TV-Out/DVI
Sound Blaster Live 2x SATA 200GB WD Hard Drives SX1040BII Black Performance Series II SOHO File Server 430W PSU
Creative Inspire 5.1 P580 Speakers Sharp LL-172G 17" LCD Monitor - Black
Morpheus is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0