Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-23-2008, 08:52 AM   #11
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: First Build

Even the 500W would be fine for him.
__________________

__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 12-23-2008, 05:14 PM   #12
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: First Build

Quote:
Originally Posted by worshipme View Post
Even the 500W would be fine for him.
yeah, either one, OCZ's are good psus...
__________________

__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 12-23-2008, 05:21 PM   #13
Fully Optimized
 
Holysky's Avatar
 
Join Date: Oct 2008
Posts: 3,692
Default Re: First Build

This is cheaper and is made by a good brand

http://www.newegg.ca/Product/Product...82E16817371019

might be a little ugly if you have a windowed case lol
Holysky is offline   Reply With Quote
Old 12-23-2008, 05:46 PM   #14
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: First Build

Quote:
Originally Posted by Holysky View Post
This is cheaper and is made by a good brand

http://www.newegg.ca/Product/Product...82E16817371019

might be a little ugly if you have a windowed case lol
that's a very good PSU, but the OCZs are cheaper when the rebate and free shipping are factored in, Antec doesn't worry about aesthetics, they just worry about making quality products, my True Power Trio isn't very "pretty" either, but is a very good psu...
__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 12-24-2008, 01:13 AM   #15
Daemon Poster
 
culexor's Avatar
 
Join Date: Mar 2006
Posts: 1,132
Send a message via AIM to culexor
Default Re: First Build

Quote:
Originally Posted by wol-va-rine View Post
yeah, he must not have seen the canadien flag...



yes, great post, do not skimp on the psu, it's probably the most important part of a build and if it is cheap and blows up it could take some other components with it, then you're back at square one...

I skimped on my first build with a Powmax Assassin, after about 9 months it pretty much assassinated itself one day while I was at work, thankfully it didn't take any other components with it when it went "Pow", plus I never got my rebate (it was $25 shipped with a $25 MIR, lesson learned from that fiasco)...

this is a very good psu and fits your criteria, a little over $90 and there's a MIR to bring it close to $60...
lol i had a powmax as well, went pow after 8 months, didnt fry anything except itself (thankfully). after that i went with yet another cheap psu (still works but i have a new one since then) but i knew it would die eventually, so i got a silverstone. its really loud, but its stable and strong, its worth the loud fans.
__________________
Desktop: Phenom II B50 3.1Ghz, 4GB DDR2 800, Gigabyte MA790X-UD4P, 2x 1TB RAID0, GTX 460 1GB, OCZ 600W, ABS Black Pearl

Laptop: i5 430M 2.26Ghz, 4GB DDR3 1066, 500GB WD Blue, Mobility Radeon HD 5650 1GB (discrete)
culexor is offline   Reply With Quote
Old 12-27-2008, 07:27 PM   #16
Baseband Member
 
Join Date: Dec 2008
Posts: 74
Default Re: First Build

thaks for all your help, sorry, i didnt see the new egg.ca part, i just never buy from there cause its to expensive, for 12 items, its over $250 to ship. Just plain dumb, i bought of ncix and 2 day shipping from british columbia to ontario for $39.95. Thanks for all your help
__________________
Case: Antec 1200 Mobo: Asus P5Q-Pro CPU: Intel dual core e8500 3.16ghz @ 4.0ghz
Ram: Kingston HyperX 4gb
GPU: HIS radeon 5870PSU Antec 650w tricool
Heatsink: Artic Cooler Freezer 7 Pro
Memory: 120gb ocz SSD, 500gb WD Black HDD
kirkman is offline   Reply With Quote
Old 12-28-2008, 02:19 AM   #17
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: First Build

Quote:
Originally Posted by cornholio101 View Post
lol i had a powmax as well, went pow after 8 months, didnt fry anything except itself (thankfully). after that i went with yet another cheap psu (still works but i have a new one since then) but i knew it would die eventually, so i got a silverstone. its really loud, but its stable and strong, its worth the loud fans.
you were a little more hard headed than me then huh...?



after the Powmax fiasco I got an Antec Basiq 500w off craigslist for $25 and ran that until a week ago when I got a Cooler Master Mystique with an Antec True Power Trio 650w already installed for $40 off craigslist, I tipped the guy $10 for holding it until I got paid, I also got my E6600 for $100 off craigslist about 2 years ago...

craigslist is my local Newegg sans shipping...

__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 12-28-2008, 02:28 AM   #18
Baseband Member
 
Join Date: Dec 2008
Posts: 100
Default Re: First Build

hehe, anythng i see on newegg, i allways search craigy, but you gotta make sure its not defaulty
__________________
Cant find something your looking for? PM me and ill find it
yuki953 is offline   Reply With Quote
Old 12-28-2008, 02:29 AM   #19
Guru
 
JogaBonito1502's Avatar
 
Join Date: Jan 2008
Location: U.S.
Posts: 7,841
Default Re: First Build

I hate buying used stuff. For me things have to be brand new. It's going to suck when it's time to buy a car lol.
JogaBonito1502 is offline   Reply With Quote
Old 12-28-2008, 02:41 AM   #20
Baseband Member
 
Join Date: Dec 2008
Posts: 100
Default Re: First Build

lol, well, also you gotta watch out for obvious and not so obvious scams, like this one, its the pictures and the faulty info that give it away
http://seattle.craigslist.org/see/sys/967867646.html

but this is a good cheep one
http://seattle.craigslist.org/oly/sys/971352282.html
__________________

__________________
Cant find something your looking for? PM me and ill find it
yuki953 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0