Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-06-2011, 09:44 AM   #1
Baseband Member
 
Join Date: May 2009
Posts: 64
Default external usb hard drive

Hi everyone I hope everyone had a good Xmas and new year, my wife bought me for Xmas a 1TB hard drive and a usb external caddy which we intend to use as a back up for all our important documents, pics, videos, etc. I have assembled it and connected it to my computer which recognises it but it is not showing up in the drives when I go to my computer which I want it to do I am running windows xp. It does show in the device manager and it is obviously recognised as I get the tell tale donk when connecting or disconnecting any suggestions welcome thanks Chris
__________________

chrisf-1 is offline   Reply With Quote
Old 01-06-2011, 12:39 PM   #2
Fully Optimized
 
Indigo's Avatar
 
Join Date: Jul 2010
Location: USA
Posts: 1,866
Default Re: external usb hard drive

This happens often with external devices in XP.

Go to Start, highlight but don't click on "My Computer"
Right click and choose "manage"

Go to Disk Management on the left

Does the drive show up in this list when it's connected to the PC? If so, right click on the drive icon in the bottom (where it shows the available space, etc) and choose "Assign or Change Drive Letter"

That should fix it. Let me know if you need clarification.
__________________

Indigo is offline   Reply With Quote
Old 01-06-2011, 01:46 PM   #3
Baseband Member
 
Join Date: May 2009
Posts: 64
Default Re: external usb hard drive

Hi og and thanks for your reply I have followed your instructions which go fine until the last bit I have right clicked on everything to do with that drive and I am not getting the option assign or change drive letter it is probably me doing something wrong but what I do not know any suggestions please.The drive has unallocated underneath it. Thanks Chris
chrisf-1 is offline   Reply With Quote
Old 01-08-2011, 07:20 PM   #4
Baseband Member
 
supernerd's Avatar
 
Join Date: Sep 2010
Posts: 30
Send a message via MSN to supernerd
Default Re: external usb hard drive

Hello chrisf-1

The option "Assign or Change Drive Letter" does not show up because the disk doesn't have a file system (it's not formatted yet). Follow og's procedure again but instead of the "Assign or Change Drive Letter" option, look for "New Partition..." and follow this procedure. The wizard is pretty straight-forward but just in-case:

1) Click Next
2) Select "Primary Partition"
3) The next window gives you the option to make multiple partitions so if you wanted to keep videos, documents, and pictures separated logically instead of through folders you could do so, but for the sake of consistency let it be and just click Next.
4) This is where you assign the drive letter. Windows automatically gives you the next letter in line, so just click next.
5) Make sure the "Format this partition with the following settings" circle is selected.
a. The first 2 input boxes should be set to [NTFS] and [default]
b. Volume label is whatever you wanna call you external drive, for example My Recovery Files.
c. Last is the "Perform a quick format" and "Enable file and folder compression" selection boxes. The first one should be unchecked only if there was data previously on it, but if this is a brand-spankin-new drive. Check the box and the second one I would recommend selecting IF and ONLY if you're using this external drive for backup files because then you can stuff more on it.
6) Before Windows does anything, you can review what you have selected to be applied to your external drive. Make sure Windows is gonna do a quick format. If you're going to do a full format...STOP. You did say this is a 1TB drive correct? While I'm not sure why it wouldn't already be partitioned but DO NOT click next just yet. 1,000 GB will take a looooooooong time to format. So...I would HIGHLY recommend doing this procedure in the evening so the drive formats overnight and even through your day of work. So make sure Windows will "Perform a quick format" and the click finish.

Now anytime you connect you're external drive to your machine, it should not require you to go back into "Disk Management" to assign it a drive letter. That really only occurs with flash drives, Lexar in particular.

Hope this works out for you.
supernerd is offline   Reply With Quote
Old 01-08-2011, 07:54 PM   #5
Daemon Poster
 
Join Date: Oct 2010
Posts: 624
Default Re: external usb hard drive

it did it to me with an internal 1TB sata drive. is it just the 1TB's and higher that this is happening to? or a fluke?
__________________
Asus M4A88T-M/USB3<>PhenomII X4 965e<>Asus ENGTX460
Seagate 320GB/1TB<>Win7 Ulti 64Bit<>Antec900
SyncMaster 2220WM<>HyperX 16gb<>Cooler Master 600W
detox is offline   Reply With Quote
Old 01-08-2011, 08:28 PM   #6
Baseband Member
 
supernerd's Avatar
 
Join Date: Sep 2010
Posts: 30
Send a message via MSN to supernerd
Default Re: external usb hard drive

detox,

The issue chrisf-1 is having was do to the hard drive being unpartitioned. It happens with any hard drive in a Windows NT architecture to the best of my knowledge(Windows NT, 2000, XP, and Server 2003). It definitely happens all the time in Windows Server 2003. It was a real "head-scratcher" for me until I figured it out too. I have purchased brand new hard drives, and installed them in systems then them not showing up in windows. Many I assume come from the factory unpartitioned, some are low-level formatted. So no, it's not just 1TB drives. But when you format it and assign a drive letter to it...that's it. You only need to do one time to that hard drive.
supernerd is offline   Reply With Quote
Old 01-09-2011, 09:36 AM   #7
Baseband Member
 
Join Date: May 2009
Posts: 64
Default Re: external usb hard drive

Thanks everyone for your help and it is now working as it should Chris
__________________

chrisf-1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0