Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-23-2010, 09:54 AM   #1
Solid State Member
 
Join Date: Feb 2010
Posts: 10
Default External Hard Drive not installing automatically

I have a WD my book essential external 500gb hard drive I just bought.
I am running windows 7 (the full verion, not a trial)
It has a USB, and an AC adapter. Both need to be plugged in.
When I first hooked it up to my laptop, It started installing, but the AC cord got detatched from the hard drive, so it couldnt complete installation.
I tried rebooting my computer, and doing the same thing, but when I did, it didnt start installing automatically. I went to the manufacturer website to see if I could find drivers for it, but the Hard drive I have doesnt have drivers because its not suppose to be neccessary.
Using the device manager to scan for new hardware doesnt detect it, and when go go devices and printers, then try to add a device, my computer crashes (blue screen of death) and when I reboot it, it says my miniwifi boot adapter or something like that is having problems, so I have to do a system restore to fix it. And my hard drive still doesnt install. By the way, I do make sure the hard drive is turned on during all of this. I am not a genius when it comes to computers, but Im not completely stupid (although I have been known to overlook obvious things quite a bit).

If anyone could help that would be great, I dont want to have to go out and replace this thing I still have the reciept if I have to though.
__________________

BluePriest is offline   Reply With Quote
Old 02-23-2010, 10:27 AM   #2
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: External Hard Drive not installing automatically

Can you see the device in device manager? If so, try uninstalling it, reboot, then try installing it again.

Also, have you tried plugging it into a different USB port?
__________________

__________________
Save the whales, feed the hungry, free the mallocs.
berry120 is offline   Reply With Quote
Old 02-23-2010, 10:42 AM   #3
Solid State Member
 
Join Date: Feb 2010
Posts: 10
Default Re: External Hard Drive not installing automatically

Its not located in the device manager. And I just tried putting it in a different usb, that didnt work either. My trackball works fine in both usb slots though, so I know they arent broken. Is there any other info that would be useful?
BluePriest is offline   Reply With Quote
Old 02-23-2010, 10:50 AM   #4
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: External Hard Drive not installing automatically

Can you install the device on another computer? It's possible (though unlikely) that disconnecting the mains cord in installation may have broken the thing. They're not designed to just be yanked out like that!

It shouldn't have killed it - but it'd be pointless chasing down errors they don't actually exist.

Also, have you tried unplugging the wifi adapter that causes the blue screen of death then adding a device? Did the thing crash like this before you tried installing the drive as well as after?
__________________
Save the whales, feed the hungry, free the mallocs.
berry120 is offline   Reply With Quote
Old 02-23-2010, 11:35 AM   #5
Solid State Member
 
Join Date: Feb 2010
Posts: 10
Default Re: External Hard Drive not installing automatically

I guess it is the drive, because i tried plugging it in to my inlaws desktop, and it didnt install. Guess ill have to go get it replaced. Thanks, I dont know why I didnt think of that sooner. The AC plug (that goes into the drive) will pull out if even the slightest amount of pressure is put on it. Probably so that it doesnt fall and break, I guess that feature backfired on me this time though.
BluePriest is offline   Reply With Quote
Old 02-23-2010, 12:37 PM   #6
Fully Optimized
 
jmacavali's Avatar
 
Join Date: Jun 2009
Posts: 4,867
Default Re: External Hard Drive not installing automatically

Or it could be a lose connector in the drive that is causing it to fall out. I had a External case that did something similar but the connector was lose on the back of the case because the cord had to be held just right to keep it from turning off. Sounds like a similar issue. I'd send it back and see if they will replace it.
__________________

__________________
****************************************
Don't take life too seriously -- no one gets out alive. Plus, who wants to arrive to the hereafter in pristine condition wearing a suit and tie?
I want to slide in sideways, worn out, used up, hair a mess, clothes tattered, & screaming, "Whooo! What a ride!"
****************************************
jmacavali is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0