Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-05-2005, 02:26 AM   #1
Baseband Member
 
delusional's Avatar
 
Join Date: Aug 2005
Posts: 33
Default Driver/DX9 issues

Hey all, I was wondering if anyone here could offer me some insight as to what is going on with my machine. My specs are in my sig, so I'll just go ahead and describe the problem.
It's really odd, CS:Source, Doom3, and FarCry, run just fine. But when I play GTA:SA, FEAR mp demo, or COD 2 demo, this is what happens:
I load the game, either in the menu or when the game loads, I get a split screen effect. The top half seems ok while the bottom half is totally out of wack. Either Wireframing or just flashing or no image at all. What could this possibly be? I have tried new drivers, old drivers, changing settings and the only thing that brough about any success was when I ran the game with single GPU rendering instead of SLI rendering. I'm also running windows x64 which maybe a problem for directx9.0c.
I'm really lost here and would appreciate any help. Also, I should add that all games worked fine before a certain time when I installed either a driver or directx, and have since then reinstalled everything to it's orignal version to no avail.

Plz help the noob!

-del
__________________

__________________
AMD FX-57 (San Diego)
eVGA GeForce 7800 Gtx 2x
ASUS A8N nForce4 SLi deluxe
Enermax Noisetaker
Corsair XMS Pro 1gb 2x
74gb WD Raptor 2x
CoolerMaster Liquid Cooling =D
3dMark05 - 12280 @ stock clockspeeds
delusional is offline   Reply With Quote
Old 10-05-2005, 07:48 AM   #2
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Driver/DX9 issues

I think it's the OS
__________________

lhuser is offline   Reply With Quote
Old 10-05-2005, 07:44 PM   #3
Baseband Member
 
delusional's Avatar
 
Join Date: Aug 2005
Posts: 33
Default Re: Driver/DX9 issues

but then why would it have worked before I updated anything? and then not work when I reverted?
__________________
AMD FX-57 (San Diego)
eVGA GeForce 7800 Gtx 2x
ASUS A8N nForce4 SLi deluxe
Enermax Noisetaker
Corsair XMS Pro 1gb 2x
74gb WD Raptor 2x
CoolerMaster Liquid Cooling =D
3dMark05 - 12280 @ stock clockspeeds
delusional is offline   Reply With Quote
Old 10-05-2005, 07:46 PM   #4
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Driver/DX9 issues

Not all drivers can rollback
lhuser is offline   Reply With Quote
Old 10-05-2005, 07:48 PM   #5
Baseband Member
 
delusional's Avatar
 
Join Date: Aug 2005
Posts: 33
Default Re: Driver/DX9 issues

hmm, I used driver cleaner pro, which deletes all nvidia files on my hd, then installed the old ones again.
__________________
AMD FX-57 (San Diego)
eVGA GeForce 7800 Gtx 2x
ASUS A8N nForce4 SLi deluxe
Enermax Noisetaker
Corsair XMS Pro 1gb 2x
74gb WD Raptor 2x
CoolerMaster Liquid Cooling =D
3dMark05 - 12280 @ stock clockspeeds
delusional is offline   Reply With Quote
Old 10-05-2005, 07:50 PM   #6
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Driver/DX9 issues

Oh...

did you upgraded you DirectX program?

Did happened a while after you had the games on right?
lhuser is offline   Reply With Quote
Old 10-05-2005, 07:52 PM   #7
Baseband Member
 
delusional's Avatar
 
Join Date: Aug 2005
Posts: 33
Default Re: Driver/DX9 issues

yea it seemed to be fine at first, then something installed a newer (or older) version of DX9 and I think thats when the problems started. Is there any possible way to revert your DX? and/or delete it and start from scratch?
__________________
AMD FX-57 (San Diego)
eVGA GeForce 7800 Gtx 2x
ASUS A8N nForce4 SLi deluxe
Enermax Noisetaker
Corsair XMS Pro 1gb 2x
74gb WD Raptor 2x
CoolerMaster Liquid Cooling =D
3dMark05 - 12280 @ stock clockspeeds
delusional is offline   Reply With Quote
Old 10-05-2005, 07:58 PM   #8
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Driver/DX9 issues

Erm, DX9 with an XP64 machine.... I don't know if it's good together


Try looking in Add/Remove Programs in the Control Panel (and check the Windows update installations) and see if it's there.

Usually, I could never have reverted a Direct X version to 8.1

I think you need to reformat...but it's not the final answer now
lhuser is offline   Reply With Quote
Old 10-05-2005, 11:27 PM   #9
Baseband Member
 
delusional's Avatar
 
Join Date: Aug 2005
Posts: 33
Default Re: Driver/DX9 issues

I guess I'm just going to go ahead and shell out the extra 180 bucks for pro. This hasn't been the only problem with x64, it's completely glitchy. I guess I'll buy pro and wait for them to get their acts together.
__________________
AMD FX-57 (San Diego)
eVGA GeForce 7800 Gtx 2x
ASUS A8N nForce4 SLi deluxe
Enermax Noisetaker
Corsair XMS Pro 1gb 2x
74gb WD Raptor 2x
CoolerMaster Liquid Cooling =D
3dMark05 - 12280 @ stock clockspeeds
delusional is offline   Reply With Quote
Old 10-06-2005, 11:02 PM   #10
In Runtime
 
acekrn's Avatar
 
Join Date: Oct 2005
Posts: 315
Default Re: Driver/DX9 issues

or you can wait for vista! lol
__________________

__________________
Asus K8V-X Motherboard
AMD 64 3000+ @ 2.0Ghz
OCZ PC3200 DDR-RAM 1Gb + 2x 512Mb
Ati Radeon x850xt, Soundblaster Audigy ZS 2
Maxtor S-ATA 60 Gig + 200 Gig Harddrives
NEC 19inch 8ms 800:1 ratio LCD1970gx
acekrn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0