Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2005, 06:21 PM   #1
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Post Debug Assertion Failed

While I assume you guys dont deal with gameing problems, this problem more so concerns a mouse problem:
When I try to start the game Battlefield 2 I get this pop up and the game fails to load. When I went to gaming forums with this problem, they told my to come here. So I did.
The pop is as follows:

BF2 Error-------------------------------------------------------------

Debug assertion failed!

Version: 1.0.2446.12 Build date: 2005-6-7 15:24
Module: Input
File:-c:\dice\Projects\BF2Branches\BF2Demo\Code\BF2\IO\I nput\MouseDevice.cpp
Line: 59

Text: InputDeviceBase error other error -2147467259

Current confile:
-----------------------------------------------------------------

I have no clue what this means, the file location it gives doesnt even exist, but Im not the computer savy so beats me. Someone help me please.
__________________

__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 06:40 PM   #2
Daemon Poster
 
The_Necromancer's Avatar
 
Join Date: Jan 2005
Posts: 1,209
Send a message via MSN to The_Necromancer
Default Re: Debug Assertion Failed

First: Is it a legal copy?
Secound: what kind of mouse do you have?
__________________

__________________
For You
The_Necromancer is offline   Reply With Quote
Old 07-10-2005, 06:46 PM   #3
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default

The game is legall yes, its just the demo. And I have a USB Logitech optical wheelmouse, it came with my 2 1/2 year old gateway comp.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 06:47 PM   #4
Daemon Poster
 
The_Necromancer's Avatar
 
Join Date: Jan 2005
Posts: 1,209
Send a message via MSN to The_Necromancer
Default Re: Debug Assertion Failed

ok, try reinstalling the drivers, and if that does not work, try Dl them from the makers web site! Also what r your Specs???
__________________
For You
The_Necromancer is offline   Reply With Quote
Old 07-10-2005, 06:48 PM   #5
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

Oh and I forgot to mention I've tried other mouses as well. I had two mouses, and when I disabled one of them the problem went away. But now when I disable it the problem is still there, I even uninstalled the other mouse and I get the pop up, Im thinking maybe theres conflicting software, but ive deleted everything I can think of related to my old mouse. I dont know what to do, which is why Im here.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 06:49 PM   #6
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

ok ill try reinstalling the driver and will post back once done.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 06:50 PM   #7
Daemon Poster
 
The_Necromancer's Avatar
 
Join Date: Jan 2005
Posts: 1,209
Send a message via MSN to The_Necromancer
Default Re: Debug Assertion Failed

ok, when you used the alternitieve mouse did it work? Also what r your PC's Specs???
__________________
For You
The_Necromancer is offline   Reply With Quote
Old 07-10-2005, 06:55 PM   #8
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

Nah when I used the other mouse I got the same thing, which made me think conflicting software. As fat as my comps specs go Im not the computer literate so bare with me and ask if theres any additional info you need.
Intel Pentium 4 - 2.53 gH
1022 mB RAM
Video Card- Radeon 9800pro 128mb

As I said earlier, I got the game to work at one point yesterday, but once I re-enabled my other mouse all hell broke loose.lol.

I reinstalled the drivers and still no luck
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 06:59 PM   #9
Daemon Poster
 
The_Necromancer's Avatar
 
Join Date: Jan 2005
Posts: 1,209
Send a message via MSN to The_Necromancer
Default Re: Debug Assertion Failed

ok, uninstall all drivers and install the good mouse I.E the one that u used yesterday!
__________________
For You
The_Necromancer is offline   Reply With Quote
Old 07-10-2005, 07:03 PM   #10
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

Is there a place to find drivers to uninstall besides the conrol panel add and remove programs?
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 07:05 PM   #11
Daemon Poster
 
The_Necromancer's Avatar
 
Join Date: Jan 2005
Posts: 1,209
Send a message via MSN to The_Necromancer
Default Re: Debug Assertion Failed

Control panel>>>> add hardware
__________________
For You
The_Necromancer is offline   Reply With Quote
Old 07-10-2005, 10:31 PM   #12
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

Ok I uninstalled and reinstalled my onw mouse driver. Still doesnt work.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 10:43 PM   #13
Fully Optimized
 
Join Date: May 2005
Posts: 1,690
Default Re: Debug Assertion Failed

You can reinstall them all day and it won't help you.
Get your model number and ID code or whatever for that computer and then go to the gateway service center and talk to them or look for bios updating FAQ.
And be careful on this because you can kill your computer if you foul it up. If you don't feel confortable with doing it then I STRONGLY suggest that you take it to a shop and have them do it for you.

edit> READ MY NEXT POST
__________________
lurkswithin is offline   Reply With Quote
Old 07-10-2005, 10:59 PM   #14
Fully Optimized
 
Join Date: May 2005
Posts: 1,690
Default Re: Debug Assertion Failed

I just got through looking at BF2 website and looking through there help/support section. There was an issue about logitechs input devices not working properly and it said that logitech has a fix for it...
BF2support linked here:
http://www.logitech.com/index.cfm/do...ho%20$p_sid%20?>

find your input device(s) and click on them and it will take you to the download file for the fix(hopefully). try this first!!! then post back as to whether it worked OR NOT.
__________________
lurkswithin is offline   Reply With Quote
Old 07-10-2005, 11:24 PM   #15
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

I had downloaded those earlier, and it didnt work. And as far as the BIOS goes, are you sure that might be an option? Remember that I was able to play the game for one night. Just a reminder.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-10-2005, 11:49 PM   #16
Fully Optimized
 
Join Date: May 2005
Posts: 1,690
Default Re: Debug Assertion Failed

you can download this utillity and look at the BIOS date and then check the BIOS upgrade date and see if they are a few years different,. If they are then more than likely you have a bios issue because of the input device failure. :
everest: http://www.majorgeeks.com/download4181.html

I believe that your input devices are restricted in the old bios. The restriction being a faster transfer of data from device to system. Your game recognizes that your input devices cannot transfer data fast enough for game play and puts the stop to it with an error message...The problem with that error message is that it is a manufacturer message for their eyes only. They do not let out their error messages to anyone..
all in all, it is just my humble opinion and please feel free to continue to find another solution.
Now you can go here and use there SAFE & FREE online scanner to run a system check and see if they come back with any other issues. They will benchmark it and test every aspect of your hardware and then show what a comparission between your system and any others with the same hardware.
http://www.pcpitstop.com
__________________
lurkswithin is offline   Reply With Quote
Old 07-12-2005, 04:05 AM   #17
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

Ok...Im working on my BIOS update right away. But before I did that I figured Id mention this pop up I got right after I installed my mouse driver. I dont know if its even related to the mouse driver installation, but just to be on the safe side heres what the pop up said:

lKernel.exe - Application Error------------------------------------------------------------------------------

The instruction at "0x4fef21fe" referenced memory at "0x0016af60". The memory could not be "read".

Click on OK to terminate the program

-----------------------------------------------------------------------------------------------------------

Just wondering what you made of this pop up.
__________________
gunslinger2787 is offline   Reply With Quote
Old 07-12-2005, 10:34 PM   #18
Solid State Member
 
Join Date: Jul 2005
Posts: 10
Default Re: Debug Assertion Failed

There arent any places you can go to get free BIOS upgrades are there. And if not where is the cheapest palce you can recommend?
__________________

__________________
gunslinger2787 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0
×