Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 03-25-2006, 01:28 PM   #1
Solid State Member
Join Date: Aug 2005
Posts: 11
Default Cursor disappears | Please Help - Urgent!


My cursor has disappeared. When I restart my PC, it stays on for a while, but then suddenly (mostly when starting a new application, any app.) it disappears. The cursor itself, the arrow, remains visible, but it gets stuck in one place, doesn't move, but when I drag my mouse, things like links in website do show an underline, buttons get highlighted, meaning the mouse cursor is working fine function wise, but the actual arrow jams at one place, so from then I have to guess the position of the cursor through moving my mouse in all directions and judging by which buttons or links show change.

Its really annoying and very surprising, I've never had this problem before. I've checked for viruses and spyware, deleted them, but the problem remains.

I have two anti-virus/firewalls on at all times, other than Windows own.

I have Windows XP, installed just a month ago, retail version brand new.

Windows XP
MSI MS-6507
Intel P4 2.0 GHz
1GB Ram
GeForce Ti 4600
Maxtor (40 GB 7200 RPM Ultra ATA/133)
entralinks is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 10:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0