Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 06-11-2011, 10:40 AM   #1
Solid State Member
Join Date: Sep 2009
Posts: 6
Default Computer acting up

Lately my computer has been acting a little strange. When watching a video the sound will skip or get stuck. It only lasts for few seconds, but it is continuous. Also the screen is fidgety. I have used two different monitors so and this has continued. Recently my place flooded and the computer was sitting on the floor. When I checked it there was a small amount of water in the bottom of the case only slightly below the motherboard. I am not sure if the motherboard got wet. Is there a way to test the motherboard to ensure it is functioning at 100%? I run my sound from my motherboard, but I have a separate video card for my monitor. I have listed below the parts I use. If the motherboard is bad can anyone point me to a good motherboard I could replace it with that would fit with the rest of my parts? Much appreciated. If you need any additional info please let me know and I can try and get it for you. I built this computer, but I am not that computer savvy, so I am not well versed in a lot of the lingo.

AMD Phenom 8650 Toliman 2.3GHz
XFX Radeon HD 4870 XXX 1GB PCIe w/Dual Link DVI
Mbutler is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0