Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 11-19-2007, 05:09 PM   #1
Beta Member
Join Date: Nov 2007
Posts: 4
Default Can't see anything on my monitor.

Okay guys.. I'm puzzled.

I recently went to a friends house because he was having some grayed/blacked out portions of his monitor. So, I assumed maybe he had a lot of dust inside the tower. I dusted it out with a can of compressed air.. Something I normally do every 6 months or so. Anyway, I quickly sprayed around and got the dust out quite nicely.

Now.. when I plugged everything back togteher, I wasn't able to see anything. It's just black. There are no computer beeps or anything(But I don't know if that did it before or what)

I checked the ram. It works.
I took out the Nvidia video card to see if I can get the internal built in card to work. I still got nothing.

What can it be? I boot to nothing but black.. I don't hear the tower thinking or anything as if it would be booting into an OS.. What's the issue here?

mmilitia9 is offline   Reply With Quote
Old 11-19-2007, 05:14 PM   #2
Site Team
T-MAN's Avatar
Join Date: Jul 2007
Location: Australia
Posts: 2,054
Default Re: Can't see anything on my monitor.

Have you checked to make sure you havent accidentely unplugged anything? I would say the power supply is gone.

1st Puter - Intel Pent D 3.4GHz, 2 GIG Ram, GeForce 9800GT, Windows 7 Home.
2nd Puter - AMD Athlon Dual Core 2.69GHz, 2 GIG Ram, GeForce 7600GT, XP Home.
Lappy - Intel Dual Core 1.73GHz, 2 GIG Ram, Vista Home Premium.
Piss off George Monks = gmcrepair? YES, YES it was.
Yeah he likes to boost his count.
T-MAN is offline   Reply With Quote
Old 11-19-2007, 05:15 PM   #3
Fully Optimized
CompMan's Avatar
Join Date: Aug 2006
Posts: 3,323
Send a message via AIM to CompMan
Default Re: Can't see anything on my monitor.

So all the fans, and lights, and hard drives spin up?
|Intel Q6600@3.0ghz||ASUS MAXIMUS FORMULA||2GiG Corsair XM2 DDR2 800||EvGa 8800GTS||36gig Western Digital Raptor 10,000 rpm||Ultra X2 connect 550W modular psu||Thermaltake Tsunami Case|Vista 64bit|
Windows has Blue screens, Mac has grey screens, and CF has White screens!!
2004 Mazda RX-8 GT Titanium Grey, Greddy Exhaust, AEM cold air intake
--objects in rearview get smaller with each shift--
CompMan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 04:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0