Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-29-2006, 07:47 AM   #1
Beta Member
 
Join Date: Nov 2006
Posts: 5
Default Can anyone help please?

Hi guys-I seem to have a problem with a works laptop, and was wondering wheather anyone would mind helping me please? Basically, I think it has a virus, as yesterday, when switched on, I would get a bx flash up, saying "C\winnit:system32\suchost.exe"-then the computer would restart itself, saying "a fatal error has occurred." I could only operati in safe mode with networking. A friend looked at it last night, and now it'll start, but no images will show-only a little box in its place, with the three coloured shapes in it. Also, the box keeps popping up, saying "C\winnit:system32\suchost.exe". There are links to something called "ExSplorer" all over it too. Is there any way I can sort this out guys, I'd really appreciate your help. Thanks, Olly.
__________________

OllyA is offline   Reply With Quote
Old 11-29-2006, 08:33 AM   #2
Golden Master
 
mammikoura's Avatar
 
Join Date: Jul 2005
Posts: 7,459
Send a message via MSN to mammikoura
Default Re: Can anyone help please?

I believe suchost.exe is a part of a trojan.
I suggest that you install AVG anti-virus (free), update it and then run it. Also start -> run -> msconfig and then try to find the trojan from there (use google to check the processes) and disable it. This will prevent it from starting when windows starts.

If everything else fails, backup all important stuff and reformat. But there are a lot of ways to take care of viruses, so usually a reformat isn't needed.
__________________

__________________
0_o
mammikoura is offline   Reply With Quote
Old 11-29-2006, 09:04 AM   #3
Beta Member
 
Join Date: Nov 2006
Posts: 5
Default Re: Can anyone help please?

Ok, thanks-I will give it a go.
OllyA is offline   Reply With Quote
Old 11-29-2006, 10:31 AM   #4
Beta Member
 
Join Date: Nov 2006
Posts: 5
Default Re: Can anyone help please?

Sorry, msconfig is not working-I have Windows 2000 if that helps. It's letting me download virus detection software, but not install and run it. Anyone else got any ideas please?
OllyA is offline   Reply With Quote
Old 11-29-2006, 10:33 AM   #5
Golden Master
 
mammikoura's Avatar
 
Join Date: Jul 2005
Posts: 7,459
Send a message via MSN to mammikoura
Default Re: Can anyone help please?

ohh, I was assuming you had win xp. And safe mode doesn't allow all programs to install, you could always try some other free anti-virus programs to see if they will install. Other good ones are Avira AntiVir and Avast.

also, give this a try. It's free online virus scan.
http://housecall.trendmicro.com/
__________________
0_o
mammikoura is offline   Reply With Quote
Old 11-29-2006, 10:35 AM   #6
Fully Optimized
 
LambOfGod's Avatar
 
Join Date: Sep 2006
Posts: 1,783
Send a message via MSN to LambOfGod
Default Re: Can anyone help please?

Quote:
Originally Posted by OllyA
Sorry, msconfig is not working-I have Windows 2000 if that helps. It's letting me download virus detection software, but not install and run it. Anyone else got any ideas please?
Yes download and run MSconfig from here

http://www.perfectdrivers.com/howto/msconfig.html

And you downloaded AVG already right?

Here is a link just for reference

AVG antivirus
http://www.download.com/AVG-Anti-Vir...g=pop.software

And you can only access the Computer in safemode?

( I am assuming safemode with networking)
__________________
LambOfGod- Q6600 g0 @ 3.06 Ghz * DFI LANPARTY DK X48-T2RS * Antec 1200 * Rosewill RP550 PSU * EVGA 8800 GTX Superclocked *WD 74GB Raptor * 2 X Seagate 1TB 7200.11 (RAID 1) * 4 GB DDR2 1022 GSKILL 5-5-5-13 * Windows 7 Ultimate 64 bit/Windows XP 64 Bit
LambOfGod is offline   Reply With Quote
Old 11-29-2006, 10:39 AM   #7
Fully Optimized
 
Spec's Avatar
 
Join Date: Aug 2005
Posts: 1,641
Default Re: Can anyone help please?

btw..avg is not going to be free in january. Id go with avast, just my opinion, catches most of the new viruses that other programs dont..allt hough avg is a good anti vir.
__________________
Thermaltake ARMOR/ mATX intelG33 Motherboard/4gb G.SKILL High Gaming Performance ddr2-1200/Radeon 3870 1gb edition/850w Thermaltake superduty psu

PokerDegenerate: Don't listen to these guys, I like the IDE makes it look vintage like a 68 Camaro SS...
Spec is offline   Reply With Quote
Old 11-29-2006, 10:44 AM   #8
Fully Optimized
 
LambOfGod's Avatar
 
Join Date: Sep 2006
Posts: 1,783
Send a message via MSN to LambOfGod
Default Re: Can anyone help please?

Quote:
Originally Posted by Spec
btw..avg is not going to be free in january. Id go with avast, just my opinion, catches most of the new viruses that other programs dont..allt hough avg is a good anti vir.
is Avast free Spec?
__________________
LambOfGod- Q6600 g0 @ 3.06 Ghz * DFI LANPARTY DK X48-T2RS * Antec 1200 * Rosewill RP550 PSU * EVGA 8800 GTX Superclocked *WD 74GB Raptor * 2 X Seagate 1TB 7200.11 (RAID 1) * 4 GB DDR2 1022 GSKILL 5-5-5-13 * Windows 7 Ultimate 64 bit/Windows XP 64 Bit
LambOfGod is offline   Reply With Quote
Old 11-29-2006, 10:49 AM   #9
Beta Member
 
Join Date: Nov 2006
Posts: 5
Default Re: Can anyone help please?

Thanks guys-no I had a guy look at the computer last night, and I can now run in normal mode-he thinks it's something to do with this "exSplorer" which is all over it. I've tried all the virus detection stuff, but the computer won't run it-almost as if the virus is immune to it. Sorry I can't describe it more accurately-thanks again for your replies-I'll try the online scan now mammikoura.
OllyA is offline   Reply With Quote
Old 11-29-2006, 11:01 AM   #10
Golden Master
 
Raffaz's Avatar
 
Join Date: Sep 2006
Posts: 6,798
Send a message via AIM to Raffaz Send a message via MSN to Raffaz Send a message via Yahoo to Raffaz
Default Re: Can anyone help please?

If ya keep getting problems then it might be worth doing a clean install, and then making sure all your AV stuff is upto date so it doesnt happen again
__________________

Raffaz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0