Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-03-2015, 09:55 PM   #1
Baseband Member
 
Gamernerd212's Avatar
 
Join Date: Feb 2013
Posts: 42
Default Build won't turn on

My build won't turn on I tried changing the graphics card and liquid cooling. The liquid cooling didn't fit and I switch back the graphics card. Also I added 2 sticks of ram of a different brand. I have a Radeon 4890 graphics card and an I7 4770k 1150 CPU. Any ideas or anything. Clueless


Sent from my iPhone using Computer Forums
__________________

Gamernerd212 is offline   Reply With Quote
Old 05-04-2015, 12:13 AM   #2
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,874
Default Re: Build won't turn on

Not knowing what your system is I'll take a wild shot. Is your CPU power plugged in?
__________________

__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 05-04-2015, 12:56 AM   #3
Golden Master
 
BK_123's Avatar
 
Join Date: Dec 2009
Location: Australia
Posts: 7,532
Default Re: Build won't turn on

Have you connected all the wires up correctly, Is your PSU powerful enough?
BK_123 is offline   Reply With Quote
Old 05-04-2015, 01:57 AM   #4
Wizard of Wires
 
setishock's Avatar
 
Join Date: Feb 2005
Location: Not sure
Posts: 10,030
Default Re: Build won't turn on

On most modern boards in the upper left for most, is a 6 or 8 pin socket. There will be specific connectors on the PSU for that socket. The CPU will not fire up with out power going to that connection.

Next is the power button on the case plugged in to the correct pins on the board.

After that did you use the standoffs in the case for the mother board. If you did make sure there is not one where a screw doesn't go through. A rouge standoff can short out a board. It either doesn't come on or it fries the board.
If you didn't use the standoffs, the board is shorting out to the case. Sometimes they will survive, sometimes not. It's a crapshoot for that.

Also in the 24 pin main plug is a green and a bunch of black wires. The green is the turn on signal for the PSU. To see if the PSU is working, jump the green and one of the black together and see if the PSU fires up. If not the PSU is shot. If it does then something else is wrong.

And did you align the arrow on the CPU to the arrow on the CPU socket? If you didn't you can kiss the chip goodbye.
setishock is offline   Reply With Quote
Old 05-04-2015, 02:47 PM   #5
Baseband Member
 
Gamernerd212's Avatar
 
Join Date: Feb 2013
Posts: 42
Default Re: Build won't turn on

My CPU power is plugged in and my PSU Is 500 w cooler master. I think I have the cords plugged in the right places. ImageUploadedByComputer Forums1430765224.584779.jpg


Sent from my iPhone using Computer Forums
Gamernerd212 is offline   Reply With Quote
Old 05-04-2015, 03:05 PM   #6
Site Team
 
celegorm's Avatar
 
Join Date: Sep 2006
Posts: 10,713
Send a message via AIM to celegorm
Default Re: Build won't turn on

Try re-seating all power connections - it's possible you bumped one. I'd also double check your video card and RAM are seated properly since you just swapped those around.
__________________
"as a fanboy i refuse to admit it and will pull countless things out of my butt to disprove it"

Team Thelegorm! Total Kills: 21 (i iz in uor profile, editsing your sigz)
celegorm is offline   Reply With Quote
Old 05-04-2015, 03:41 PM   #7
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,874
Default Re: Build won't turn on

I'm thinking maybe you misplaced your power button plug. Check that.
__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 05-04-2015, 03:53 PM   #8
Baseband Member
 
Gamernerd212's Avatar
 
Join Date: Feb 2013
Posts: 42
Default Re: Build won't turn on

Power button was plug in wrong spot that it was color coded but I just had to read the label. I appreciate it a lot it was very helpful. Thought I broke it.


Sent from my iPhone using Computer Forums
Gamernerd212 is offline   Reply With Quote
Old 05-04-2015, 03:55 PM   #9
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,874
Default Re: Build won't turn on

So it's fixed then?
__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 05-04-2015, 03:58 PM   #10
Baseband Member
 
Gamernerd212's Avatar
 
Join Date: Feb 2013
Posts: 42
Default Re: Build won't turn on

Yes it is! Simple mistake on my part.


Sent from my iPhone using Computer Forums
__________________

Gamernerd212 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0