Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 05-13-2006, 03:54 PM   #1
In Runtime
Renegadeandy's Avatar
Join Date: Apr 2006
Posts: 291
Send a message via MSN to Renegadeandy
Default The bloomin drive!


I have this 120 gb Maxtor DiamondMax Plus 9 harddrive.

It has worked fine up until a couple weeks back. Basically Bios doesnt detect it, it does however spin when you turn the pc on - you can hear is power up like it should. There are absolutely no phsyical issues with the drive at all, except one of the 4 power pins seems a little turned in - so the 3 pronged edge is only really 2 and the hole in the prong is missing - but this shouldnt make a difference as ample contact with the metal shield of the plug is still made.

Why should this drive refuse to be found - i have tried various pcs, IDE ribbons, power cables - jumper settings - the lot!

Please help me save this wonderful drive! I could really do the the extra space.

Thanks guys - andy
Referred to by : UK31337

Visit http://www.pens2paper.com - For Your Stationery Needs!
Renegadeandy is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 11:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0