Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 03-10-2007, 02:26 AM   #1
Solid State Member
Join Date: Mar 2007
Posts: 7
Send a message via Yahoo to drlalitv
Unhappy BIOS blues :(

i changed the BIOS with an update(supposedly) of my ACER travelmate 4150 laptop, now the computer doesnt show anything at all when switched on..i think the BIOS ruined it..anyway it can be reversed.?
this happened because while installing fresh win xp sp2(genuine) the computer used to switch off by itself in a few seconds..it was suggested in this forum that i remove the extra add on 1 GB RAM which i did.but to no avail..is it the death of my beloved laptop???
Intel centrino 1.73 GHz,256 MB RAM,60 GB HDD

drlalitv is offline   Reply With Quote
Old 03-10-2007, 02:55 AM   #2
Daemon Poster
Anubis1980's Avatar
Join Date: Jul 2006
Posts: 1,308
Send a message via MSN to Anubis1980 Send a message via Yahoo to Anubis1980
Default Re: BIOS blues :(

No it isnt the death, before i say anything else lol, my mate had same problem, we found a company in italy which fixed the bios for 18 euros or so, within a week we had working pc again!! so dont worry

Also i would email the maker of the laptop, cos sometimes u can use a floppy with a bios image on to redo the bios even if the pc isnt coming on. It can access the floppy, as the video is often the first thing to go when a bios is damaged. If yo u cant get it fixed soon, let me know and i can pass on the email of the company in Italy, u will need to remove the bios iurself, this shud be easy if it isnt soldered on...

Good luck.

Intel C2D E6750 (1333fsb) 2.66 @3.5ghz |EVGA 680i SLI Mobo | 2GB Twin XMS ddr800 @ 875 | Leadtek 7950 GX2 Core@601 Mem@1600
500GB IBM/HITACHI Sata2 7200/16MB | 160GB 7200rpm 8mb UDMA133 Maxtor | XION 600w dual 12v 44A total SLI PSU | X-fi Xtreme Music | 22" Widescreen Acer LCD
Anubis1980 is offline   Reply With Quote
Old 03-10-2007, 06:49 AM   #3
Fully Optimized
Join Date: Nov 2006
Posts: 3,623
Send a message via AIM to ߧ∩H♠H䎀
Default Re: BIOS blues :(

Theres probally a manual reset somewhere on the motherboard to flash it back to its default version. Wereabouts that would be I have no clue.
ߧ∩H♠H䎀 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 10:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0