Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-16-2008, 02:18 PM   #1
In Runtime
 
Aimher3's Avatar
 
Join Date: Feb 2007
Posts: 203
Send a message via AIM to Aimher3
Default ATI 4870? Cmon

well i just picked one up in replace of an 8800gts 320. well as of today im kinda getting disapointed. i cant seem to push the fps i was hoping for in COD4 and a few other games. im getting kinda sick of gettin low FPS on games i like to play.


fps im getting is around 30-170 < dont mind 170 i would like to stay in the 100's all the time.maybe 130's but yeah. 4870 shouldnt drop like this. i got some mix reviews from a couple computer places around my area. but most of them said it was my power supply. not pushing. enough. bottleneck?!!??? idk


im running 6400+ black edition
500Watt Apevia
4GB G.SkiLL
asus m2n sli deluxe
__________________

__________________
| Asus M2n-SLI delux |-| AMD 6400+ |-| ocz DFI Special Edition Dual Channel 2GB 800mhz |-| Evga 8800 GTX |-| 100 GB seagate Internal |

Add Rep Im Cool :D
Aimher3 is offline   Reply With Quote
Old 10-16-2008, 03:25 PM   #2
Golden Master
 
Cabbs's Avatar
 
Join Date: Jan 2006
Posts: 7,912
Send a message via AIM to Cabbs
Default Re: ATI 4870? Cmon

Did you uninstall your old drivers before you installed the ATi drivers? Also, are they the latest? I would use driver cleaner and reinstall the drivers again.
__________________

Cabbs is offline   Reply With Quote
Old 10-16-2008, 03:29 PM   #3
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: ATI 4870? Cmon

Seems to me like its your processor, if anything.
Its a single core right?
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 10-16-2008, 03:37 PM   #4
j03
~~~~~~~~
 
Join Date: Jan 2005
Location: Wales
Posts: 5,556
Send a message via MSN to j03
Default Re: ATI 4870? Cmon

No, that's dual core AFAIK.
j03 is offline   Reply With Quote
Old 10-16-2008, 03:40 PM   #5
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: ATI 4870? Cmon

Sorry.
Then I don't see anything that's been listed that would cause that.
Resolution? antialising level?
I doubt it'd be the power supply, since it's keeping the computer up.
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 10-16-2008, 03:56 PM   #6
Fully Optimized
 
_-..zKiLLA..-_'s Avatar
 
Join Date: Nov 2007
Posts: 3,952
Send a message via AIM to _-..zKiLLA..-_
Default Re: ATI 4870? Cmon

yeah sounds like theres a problem somewhere because with ur system you should be getting great fps
__________________
My beast lappy: Acer netbook, 1.6ghz atom dual core, 2gb ddr3
My PSN: Kalikid_420
_-..zKiLLA..-_ is offline   Reply With Quote
Old 10-16-2008, 04:03 PM   #7
In Runtime
 
Aimher3's Avatar
 
Join Date: Feb 2007
Posts: 203
Send a message via AIM to Aimher3
Default Re: ATI 4870? Cmon

yeah man. i just dont understand..and i did a reformat with the new card and installed Catalyst 8.9 the latest drivers...DX9c Windows XP pro sp3 tried sp2 same situation. so idkkk someone has to figure something out.
__________________
| Asus M2n-SLI delux |-| AMD 6400+ |-| ocz DFI Special Edition Dual Channel 2GB 800mhz |-| Evga 8800 GTX |-| 100 GB seagate Internal |

Add Rep Im Cool :D
Aimher3 is offline   Reply With Quote
Old 10-16-2008, 04:13 PM   #8
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: ATI 4870? Cmon

The power supply wouldn't reduce performance if it was the problem, just cause freezes/restarts. etc.

Do this: Control Panel -> add/remove programs -> ATi drivers (if XP)/ CCC install manager (if Vista, and select remove all) -> Reboot in safe mode and run Driver Sweeper (select ATi-display) -> Reboot again and install Catalyst 8.10

Also, what resolution are you playing at? If it's at a low resolution then it most definitely is your CPU bottlenecking. The performance difference between the 8800GTS and the 4870 will only be seen when you go up the res.
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 10-16-2008, 04:19 PM   #9
In Runtime
 
Aimher3's Avatar
 
Join Date: Feb 2007
Posts: 203
Send a message via AIM to Aimher3
Default Re: ATI 4870? Cmon

im only playin at 1280x1024. only got a 19" LCD lol but yeah i think even at that low of res i should be puttin out more then 100 fps at all times. no?

also y 8.1?
__________________
| Asus M2n-SLI delux |-| AMD 6400+ |-| ocz DFI Special Edition Dual Channel 2GB 800mhz |-| Evga 8800 GTX |-| 100 GB seagate Internal |

Add Rep Im Cool :D
Aimher3 is offline   Reply With Quote
Old 10-16-2008, 04:22 PM   #10
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: ATI 4870? Cmon

8.10, not 8.1. This is ATi's driver naming scheme, not maths

Quote:
i think even at that low of res i should be puttin out more then 100 fps at all times. no?
You cannot compare your results with review sites, they could be running a completely different system, different graphics settings, AA/AF etc...
__________________

__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0