Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-08-2009, 10:12 AM   #1
Baseband Member
 
Join Date: Dec 2007
Posts: 26
Default Anyone else having problems with firefox?

I live in a college dorm and I was talking to a couple guys on my floor and they all said that firefox was really laggy and glitchy/slow for them too. I see problems especially in things like facebook and such. I was wondering if anyone else was having problems with firefox too?
__________________

raceface is offline   Reply With Quote
Old 09-08-2009, 10:25 AM   #2
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: Anyone else having problems with firefox?

No, not really.
Social sites seem to slow down over the course of the day anyway, as they are much bigger now than you can imagine, and have so much running behind them.

IE for me still remains a lot slower.

The fact that you are living in a dorm isn't helping, as you are all most likely sharing one large connection, so if you all went on a site at once, say bye to speed.
__________________

__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 09-08-2009, 10:26 AM   #3
In Runtime
 
Join Date: Mar 2009
Posts: 224
Send a message via MSN to jikifreak
Default Re: Anyone else having problems with firefox?

Thats social sites for you. I hate them cause they are the main sites of choice for hackers, and all.
__________________
Rosewill Conqueror|ASRock A780GXE AM2+|Phenom II X4 940@3.0Ghz Stock|Zalman 9900|8GB G.Skill DDR2 800|OCZ StealthXStream 700W|XFX Ati Raedeon 5770 1gb GDDR5 DX11|16X Samsung DVD-RW|360GB(SATA), 40GB(SATA), 160GB(SATA), 200GB(IDE) 500GB External(USB 2.0)|Windows 7 64Bit|19inch LCD Widescreen at 1400X900 Resolution via DVI|
jikifreak is offline   Reply With Quote
Old 09-08-2009, 12:59 PM   #4
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,004
Default Re: Anyone else having problems with firefox?

for me I find that I generally have about three windows open.
each with multiple tabs...

today I had this situation, window 1 has three tabs in it, (yahoo mail and CF)
window 2 had about ten ebay auctions in seperate tabs that I was looking at,

window 3 had about 8 tabs open on various stuff, and Firefox was running like a three legged dog.

a quick look at task manager tells me why, it's using over 1GB of memory in it's own!

it's a shame, Firefox used to be a fast, really compatible browser, now it seems even more resource intensive and bloated than IE.
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 09-08-2009, 01:03 PM   #5
Golden Master
 
Cabbs's Avatar
 
Join Date: Jan 2006
Posts: 7,912
Send a message via AIM to Cabbs
Default Re: Anyone else having problems with firefox?

IE remains the slowest for me, with Opera 10 behind Firefox 3. I never looked to see if they fixed Firefox's memory hole, but it hasn't slowed down on me. That's probably because I'm running 4GB of RAM on both my laptop and desktop.

The one thing about Firefox is that it doesn't handle Flash very well in my experience.
__________________
=Like anime? Come to AnimeAppeal.com!=
||DFI UT P35||Q9550@3400 Mhz||Geil 4GB RAM||Radeon 5770||
Cabbs is offline   Reply With Quote
Old 09-09-2009, 05:01 AM   #6
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,004
Default Re: Anyone else having problems with firefox?

Meh, I had thought that the problem was that I'd left the window open for days.

but now, I've got two tabs open, yahoo mail and CF and it uses over 100MB of memory to display these two web pages.

I know that there is a bug in 3.5 regarding large table displays, so firefox can crash quiet easily when using yahoo mail if you have a lot of items in your inbox, but I don't I've got 16 items...

i think it might be time for me to go and try opera or something and see if I have any more luck.
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 09-09-2009, 01:42 PM   #7
In Runtime
 
Join Date: Mar 2005
Posts: 408
Default Re: Anyone else having problems with firefox?

I have been having alot of problems with firefox ever since the last update. It seems to take like 5-10 seconds to open my homepage(google) and any other page I go to, and sometimes does not load a page, I have to refresh for it to load. It has also crashed a couple times for the first time ever. I am on 15mbps download and 1mbps upload. Newsleecher still works at max download as well as downloading anything from websites. It just seems to be Firefox that is really slow.
__________________
[Case = Corsair 400R][CPU = Core i5 3.4Ghz to 4.6Ghz /w Noctua NH-U12P SE2 CPU Cooler][Mobo = Asus P8Z77-V LK][RAM = 16GB DDR3 Patriot Viper 3 1600Mhz RAM][Video Card = PNY GTX 670][SSD = 240GB Force GT][Samsung S27B350 27inch monitor][Running Windows 7 64Bit]
OTSS is offline   Reply With Quote
Old 09-09-2009, 02:31 PM   #8
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: Anyone else having problems with firefox?

Few issues with Firefox.

It takes a while to load up first time and it crashes for no apparent reason.

But I also use Opera 10 which I think is brilliant with no troubles what so ever.
__________________

__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0