Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-04-2008, 10:58 AM   #1
Daemon Poster
 
Steemax's Avatar
 
Join Date: Feb 2006
Location: USA
Posts: 590
Send a message via AIM to Steemax Send a message via MSN to Steemax Send a message via Yahoo to Steemax
Default Amps, 12v rail, and video cards.

I don't understand anything about the 12v rail or the amps it provides, the vid card but does this http://www.newegg.com/Product/Produc...82E16817709011 provide good power for my x1950pro?

Im asking this because Im not able to overclock very well.
__________________

__________________
| Intel Core i7 4770K | Nvidia GTX 770OC | Samsung EVO 500GB SSD | Carbide 400R | Corsair Vengeance 16gb DDR3 | Corsair 750TXV2 PSU | Corsair Hydro 100i | Gigabyte Z87 Mobo |
Steemax is offline   Reply With Quote
Old 01-04-2008, 12:39 PM   #2
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: Amps, 12v rail, and video cards.

+12V@25A

Should be enough yeah. One person stated though that it had irregularities on the 12v by around 0.6v. Not really a problem, but it'd get lower marks for it if you wanted to overclock.

Seems like a very cheap PSU though, but didn't Sunbeam make the Tuniq Tower?
__________________

__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 01-04-2008, 02:08 PM   #3
Daemon Poster
 
Steemax's Avatar
 
Join Date: Feb 2006
Location: USA
Posts: 590
Send a message via AIM to Steemax Send a message via MSN to Steemax Send a message via Yahoo to Steemax
Default Re: Amps, 12v rail, and video cards.

Sunbeam has some decent quality cases, but I was just wondering becuase my cousin has the same card as me but i can only get my core to 608 any even one more then that and drivers stop responding while playiing games and temps dont even hit 50. while his auto clock notches his at 621 and his works perfectly.. but he is using the OCZ 700 Watt stealth
__________________
| Intel Core i7 4770K | Nvidia GTX 770OC | Samsung EVO 500GB SSD | Carbide 400R | Corsair Vengeance 16gb DDR3 | Corsair 750TXV2 PSU | Corsair Hydro 100i | Gigabyte Z87 Mobo |
Steemax is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0