Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 03-24-2012, 09:44 PM   #1
Beta Member
Join Date: Mar 2012
Location: United States
Posts: 1
Default Alienware M15x

I'm having a problem with my M15X It won't turn on when I try it blinks the lights on the touch panel and spins the gpu fan for just a second(the cpu fan twitches never spins) then goes off and then it repeats this over and over again. I have tried the power drain and checked to make sure everything is seated properly I'm at a loss. It is out of warranty naturally and I can't afford to replace it. I hope some one can help.

crobson1985 is offline   Reply With Quote
Old 03-26-2012, 02:18 PM   #2
Fully Optimized
cboucher's Avatar
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Alienware M15x

When you plug in the charger does it seem to be loose? You may have a cracked solder joint or two on the power connector...
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 03:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0