Go Back   Computer Forums > General Electricals
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 04-24-2010, 11:53 PM   #1
foothead's Avatar
Join Date: May 2009
Location: Louisiana
Posts: 9,629
Default Sony LX300USB skips a lot

I got a Sony ps-lx300usb turntable from borders last weekend, and it sounds allright, except for one major issue, where it skips on pretty much every album I have. The turntable's tracking weight is permanently set way higher than I would like, so that is not the issue, and it has a brand new needle. The skips are totally random, and even occur on a perfect album with no scratches. This is getting very frustrating, because my technics sl-qp33, which I have balanced so the tracking weight is near zero never skips. What is going on? I cannot possibly find a reason for this.

Edit: skips are both forwards and backwards, though most go backwards.
Account no longer active. Contact info available in profile, if anyone cares to reach me.
foothead is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 05:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0