Go Back   Computer Forums > General Electricals
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-26-2017, 06:24 PM   #1
Beta Member
 
Join Date: Apr 2017
Location: USA
Posts: 1
Question I'm having trouble with my BM-100FX mic.

Hello, I just recently bought a BM-100FX Floureon mic.
It's supposedly a "plug-and-play" mic, but I plugged both the USB and 3.5 mm cable into my computer, and have yet to see a working mic. The XLR cable is plugged in as well, and I checked the mic properties and it says that it recognizes the 3.5 mm jack but not the USB. From what I've come to understand is that it needs to recognize both. I've tried unplugging and plugging in and whenever I tried to join discord to talk to my friends their ears were attacked by a loud screeching noise (feedback? What's the noise?).
__________________

__________________
lordjesushelpme is offline   Reply With Quote
Old 04-26-2017, 11:09 PM   #2
Golden Master
 
BK_123's Avatar
 
Join Date: Dec 2009
Location: Australia
Posts: 7,557
Default Re: I'm having trouble with my BM-100FX mic.

Have you tried troubleshooting the audio/sound settings in Windows. If not then download the troubleshooter then follow the instructions from this Microsoft Support page Fix sound problems.
__________________
BK_123 is offline   Reply With Quote
Reply

Tags
audio, bm-100fx, issues, microphone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0