Go Back   Computer Forums > General Computing > Cyber Safety and Computer Security
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-30-2010, 07:54 AM   #1
In Runtime
 
Join Date: Jul 2009
Posts: 136
Default My Search Engine is Whack!

My friend is Google.

But for the last couple of weeks when I enter a search I get redirected to a couple of very generic looking search sites,one is commonly called Searchfidsite.com and a couple of other ones.

This doesn't happen every time,probably 30% of the searches.If I arrive at one, I click the google box again and then end up with the google results as normal.

When I first noticed this happening I did not occur very often,now it seems more frequent,maybe 1 out of 3 google searches.

AVG hasn't picked up anything unusual lately,and AVG does a nightly scan.Last night's scan found a few trojan horses and got rid of them,but that is the first incidence of AVG finding anything,while this search thing has been happening a few weeks.

I haven't done anything unusual,web wise, or downloaded anything unusual or opened any attachments lately.

Any suggestions?
__________________

__________________
I heartily recommend Root-a-pedia! It's all I use. Never let's you down.
Juan handed is offline   Reply With Quote
Old 01-30-2010, 08:16 AM   #2
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: My Search Engine is Whack!

Download and run Malwarebytes.

It might pick up something thats causing this.
__________________

__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Old 01-30-2010, 08:52 AM   #3
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: My Search Engine is Whack!

You have a browser hijacker.
Like Reminiz said, run malwarebytes and that will probably take care of it.

Have you installed any search toolbars? I've seen a few that do this.

If not, then check any browser plugins that you have installed and see if there's anything odd.
foothead is offline   Reply With Quote
Old 01-31-2010, 05:23 AM   #4
Baseband Member
 
Join Date: Jan 2010
Posts: 61
Send a message via AIM to Rickeh69 Send a message via MSN to Rickeh69
Default Re: My Search Engine is Whack!

Try clearing your hosts file too, here's where it's located.

Windows 7: C:\windows\system32\drivers\etc\hosts
Windows XP: C:\windows\system32\drivers\etc
Windows 2000: C:\WINNT\SYSTEM32\DRIVERS\ETC
Windows 95/98: C:\WINDOWS
__________________
I hope I can help you in the future. Please feel free to contact me at anytime for IT-related questions.
Rickeh69 is offline   Reply With Quote
Old 01-31-2010, 10:00 AM   #5
In Runtime
 
Join Date: Jul 2009
Posts: 136
Default Re: My Search Engine is Whack!

Quote:
Originally Posted by Remeniz View Post
Download and run Malwarebytes.

It might pick up something thats causing this.
I downloaded the free version,ran it,did the quick scan...it picked up 25 trojan related items.

So,I deleted those items and we shall see.

I ran about 20 google searches last nite and the bogus search result only happened once,that was prior to running the Malwarebytes.

How often do you recommend running the scan? should I go with quick scan or full scan? Is there anything to watch out for prior to deleting any of the items that the program finds?

Thanks,you guys are the best.
__________________
I heartily recommend Root-a-pedia! It's all I use. Never let's you down.
Juan handed is offline   Reply With Quote
Old 01-31-2010, 01:50 PM   #6
In Runtime
 
SPuNKYbd's Avatar
 
Join Date: Jan 2010
Location: USA
Posts: 236
Send a message via AIM to SPuNKYbd Send a message via MSN to SPuNKYbd Send a message via Yahoo to SPuNKYbd Send a message via Skype™ to SPuNKYbd
Default Re: My Search Engine is Whack!

With that much picked up, id reinstall windows and backup stuff as neccesary.

Viruses tend to be made of 3+ pieces when one is deleted or moved the others put it back together, chances of actually removing a virus are none to slim.

Of course, see what happens first.. maybe your the slim =P
__________________
MCDST - MCP - MCTS
SPuNKYbd is offline   Reply With Quote
Old 01-31-2010, 05:30 PM   #7
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: My Search Engine is Whack!

Quote:
Originally Posted by Juan handed View Post
I downloaded the free version,ran it,did the quick scan...it picked up 25 trojan related items.

So,I deleted those items and we shall see.

I ran about 20 google searches last nite and the bogus search result only happened once,that was prior to running the Malwarebytes.

How often do you recommend running the scan? should I go with quick scan or full scan? Is there anything to watch out for prior to deleting any of the items that the program finds?

Thanks,you guys are the best.
Definitely run the full scan no matter how long it takes. With a streamlined OS install it shouldn't take that long.

Run the app. if you suspect something is taking control of/re-configuring your system. The last time for me?... about 4 years ago and I just re-installed. But it also depends on your browsing habits too. Be careful where you go. Avast! AV software prompts you when/if your about to browse dangerous territory and if you torrent/DL/UL a lot then have a separate folder for these so you can scan the whole lot in one shot.

__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Old 02-04-2010, 08:21 AM   #8
In Runtime
 
Join Date: Jul 2009
Posts: 136
Default Re: My Search Engine is Whack!

Thanks again,guys.
I ran the full scan(malwarebytes),and picked up one item: Backdoor Bot .
Restarted and ran another scan,things were clean.

I'm going to keep an eye on it and run another scan daily for a week,to see what happens.

If my scans are coming up clean with malwarebytes,can I feel everything is OK?
__________________

__________________
I heartily recommend Root-a-pedia! It's all I use. Never let's you down.
Juan handed is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0